Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PlaySoundAtEntity not working :( (Help Needed!)
Statyk Offline
Schrödinger's Mod

Posts: 4,390
Threads: 72
Joined: Sep 2011
Reputation: 241
#11
RE: PlaySoundAtEntity not working :( I need HELP!

A .ogg is an audio file. It is what you hear.

A .snt is a text file that organizes variables for the sound, such as volume, loop, sound distance, and what list of sounds can be played.
10-17-2012, 09:43 PM
Find Reply
4WalledKid Offline
Member

Posts: 107
Threads: 23
Joined: Oct 2012
Reputation: 1
#12
RE: PlaySoundAtEntity not working :( I need HELP!

(10-17-2012, 09:43 PM)Statyk Wrote: A .ogg is an audio file. It is what you hear.

A .snt is a text file that organizes variables for the sound, such as volume, loop, sound distance, and what list of sounds can be played.
And what about if I want one specific sound from the .snt? What can I do?

[Image: 4walledkidbanner_zps1514b7f6.png]
10-17-2012, 09:52 PM
Website Find Reply
FlawlessHappiness Offline
Posting Freak

Posts: 3,980
Threads: 145
Joined: Mar 2012
Reputation: 171
#13
RE: PlaySoundAtEntity not working :( I need HELP!

I would create a new sound.
Take the .ogg file you want.
Call it something else, and then take any .snt file, and edit it so it works with the new .ogg file.
Put the 2 files in the same folder with your custom story.

Trying is the first step to success.
10-17-2012, 09:57 PM
Find Reply
4WalledKid Offline
Member

Posts: 107
Threads: 23
Joined: Oct 2012
Reputation: 1
#14
RE: PlaySoundAtEntity not working :( I need HELP!

(10-17-2012, 09:57 PM)beecake Wrote: I would create a new sound.
Take the .ogg file you want.
Call it something else, and then take any .snt file, and edit it so it works with the new .ogg file.
Put the 2 files in the same folder with your custom story.
Do I have to specify the folder where the 2 files are in the script?

[Image: 4walledkidbanner_zps1514b7f6.png]
10-17-2012, 10:21 PM
Website Find Reply
FlawlessHappiness Offline
Posting Freak

Posts: 3,980
Threads: 145
Joined: Mar 2012
Reputation: 171
#15
RE: PlaySoundAtEntity not working :( (Help Needed!)

I'm not quite sure about that... It makes no harm doing it i guess...

Now i've got the exact same question as 4WalledKid...
PlaySoundAtEntity("ThrowUpSound", "16_water_stream_low.snt", "Player", 0, false);

This won't play in my map. The scripts work fine. I get no errors, but this sound won't play. Really driving me nuts, since throwing up without sound is pretty.... boring...

Trying is the first step to success.
10-17-2012, 11:22 PM
Find Reply
Statyk Offline
Schrödinger's Mod

Posts: 4,390
Threads: 72
Joined: Sep 2011
Reputation: 241
#16
RE: PlaySoundAtEntity not working :( (Help Needed!)

(10-17-2012, 11:22 PM)beecake Wrote: I'm not quite sure about that... It makes no harm doing it i guess...

Now i've got the exact same question as 4WalledKid...
PlaySoundAtEntity("ThrowUpSound", "16_water_stream_low.snt", "Player", 0, false);

This won't play in my map. The scripts work fine. I get no errors, but this sound won't play. Really driving me nuts, since throwing up without sound is pretty.... boring...
1) Be careful, that sound loops.
2) Does anything else in that part of the script work?
10-18-2012, 01:15 AM
Find Reply
FlawlessHappiness Offline
Posting Freak

Posts: 3,980
Threads: 145
Joined: Mar 2012
Reputation: 171
#17
RE: PlaySoundAtEntity not working :( (Help Needed!)

Yep anything else works Wink As you can see i am making a "Throw up cutscene".
Thats why i named the sounds, so i could remove it again. It just aint playing at all..

EDIT: I found something... It seems that i don't have the .ogg file... only the .snt..

Trying is the first step to success.
(This post was last modified: 10-18-2012, 10:17 AM by FlawlessHappiness.)
10-18-2012, 09:33 AM
Find Reply




Users browsing this thread: 1 Guest(s)