Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How do you turn off the "hand" icon when looking at a Area trigger?
jssjr90 Offline
Member

Posts: 169
Threads: 39
Joined: Jun 2011
Reputation: 0
#1
Wink  How do you turn off the "hand" icon when looking at a Area trigger?

I have a bit of a problem. Every time I create a new trigger area, and look at it with the cross hair, It will show up as a hand icon, which takes the immersion away allot. Now I think it does this on "Entity Interact Callback" But when I also use the other callbacks, like collide and such, it still shows the hand icon. I have seen in many other custom story's where when you are looking at the trigger area in a collide function, the hand icon does not show up, but it does for me. Does anybody know how to turn off the hand icon when looking at a trigger area collide callback type?
(This post was last modified: 01-04-2013, 08:19 PM by jssjr90.)
01-03-2013, 10:33 PM
Find Reply
i3670 Offline
Posting Freak

Posts: 1,308
Threads: 74
Joined: Oct 2011
Reputation: 36
#2
RE: How do you turn off the "hand" icon when looking at a Area trigger?

You have an interact-callback either in the script or in the area itself.

"What you think is irrelevant" - A character of our time

A Christmas Hunt
01-03-2013, 11:32 PM
Find Reply
jssjr90 Offline
Member

Posts: 169
Threads: 39
Joined: Jun 2011
Reputation: 0
#3
RE: How do you turn off the "hand" icon when looking at a Area trigger?

(01-03-2013, 11:32 PM)i3670 Wrote: You have an interact-callback either in the script or in the area itself.

I don't quit understand, how do you do that?
01-04-2013, 12:05 AM
Find Reply
NaxEla Offline
Senior Member

Posts: 415
Threads: 5
Joined: Dec 2012
Reputation: 28
#4
RE: How do you turn off the "hand" icon when looking at a Area trigger?

I'm not really sure what you mean by "trigger area", so I'm going to assume you mean Script Area.

In your script, add this to your OnEnter function.

PHP Code: (Select All)
void OnEnter()
{
    
SetEntityInteractionDisabled("AreaName"true);


In Ruins [WIP]
01-04-2013, 12:12 AM
Find Reply
i3670 Offline
Posting Freak

Posts: 1,308
Threads: 74
Joined: Oct 2011
Reputation: 36
#5
RE: How do you turn off the "hand" icon when looking at a Area trigger?

(01-04-2013, 12:12 AM)NaxEla Wrote: I'm not really sure what you mean by "trigger area", so I'm going to assume you mean Script Area.

In your script, add this to your OnEnter function.

PHP Code: (Select All)
void OnEnter()
{
    
SetEntityInteractionDisabled("AreaName"true);


EDIT: missread

Do you have any text in the PlayerInteractCallback under the "Area" tab in the script area?

"What you think is irrelevant" - A character of our time

A Christmas Hunt
(This post was last modified: 01-04-2013, 12:25 AM by i3670.)
01-04-2013, 12:16 AM
Find Reply
NaxEla Offline
Senior Member

Posts: 415
Threads: 5
Joined: Dec 2012
Reputation: 28
#6
RE: How do you turn off the "hand" icon when looking at a Area trigger?

(01-04-2013, 12:16 AM)i3670 Wrote:
(01-04-2013, 12:12 AM)NaxEla Wrote: I'm not really sure what you mean by "trigger area", so I'm going to assume you mean Script Area.

In your script, add this to your OnEnter function.

PHP Code: (Select All)
void OnEnter()
{
    
SetEntityInteractionDisabled("AreaName"true);


He doesn't want the hand icon. That script would add it.

Do you have any text in the PlayerInteractCallback under the "Area" tab in the script area?

Actually no, it would not add it. It's saying that it's TRUE that interaction with the entity will be DISABLED.

In Ruins [WIP]
01-04-2013, 12:24 AM
Find Reply
jssjr90 Offline
Member

Posts: 169
Threads: 39
Joined: Jun 2011
Reputation: 0
#7
RE: How do you turn off the "hand" icon when looking at a Area trigger?

Hmm having trubble with this from the suggestions. Here is what I have for a simple test script.
The hand icon still shows up when looking at the script area.

//HAND ICON OFF on script area

void OnEnter()
{
AddEntityCollideCallback("Player","ScriptArea_156", "ScriptArea_156func", false, 1);
SetEntityInteractionDisabled("ScriptArea_156", true);
}

//Functionvoid ScriptArea_156func(string &in asParent, string &in asChild, int alState)
{
SetMessage("Message", "Thaughts23b", 5);
}
(This post was last modified: 01-04-2013, 12:43 AM by jssjr90.)
01-04-2013, 12:41 AM
Find Reply
NaxEla Offline
Senior Member

Posts: 415
Threads: 5
Joined: Dec 2012
Reputation: 28
#8
RE: How do you turn off the "hand" icon when looking at a Area trigger?

I have no clue. All I an say is make sure that it is a Script Area and not any other type of area.

In Ruins [WIP]
01-04-2013, 01:34 AM
Find Reply
jssjr90 Offline
Member

Posts: 169
Threads: 39
Joined: Jun 2011
Reputation: 0
#9
RE: How do you turn off the "hand" icon when looking at a Area trigger?

Don't worry it is a script area. Well maybe if I look in the original amnesia levels, maybe I can get somewhere with that.
01-04-2013, 01:35 AM
Find Reply
Statyk Offline
Schrödinger's Mod

Posts: 4,390
Threads: 72
Joined: Sep 2011
Reputation: 241
#10
RE: How do you turn off the "hand" icon when looking at a Area trigger?

I believe you're looking for this function:

void ShowPlayerCrossHairIcons(bool abX);
01-04-2013, 03:27 AM
Find Reply




Users browsing this thread: 1 Guest(s)