Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Steam for Linux: Amnesia not taking launch options
Drozd Offline
Junior Member

Posts: 7
Threads: 3
Joined: Aug 2012
Reputation: 0
#1
Solved: 4 Years, 6 Months, 3 Weeks ago Steam for Linux: Amnesia not taking launch options

Hello,

basicly, Amnesia is not taking launch options
Amnesia: The Dark Descent (right click) -> Properties -> Set Launch Options...
when i tried to run Winter Nights custom story (wn_config/main_init.cfg).
However running manualy from prompt, it worked.

I wrote an issue report on GitHub: https://github.com/ValveSoftware/steam-f...issues/584

I was not sure if Steam's fault or Amnesia's issue.

I made an investigation today and realized that Steam is runnig run_steam.sh which is not using $1 variable (or any other). So I rewrote it:
-    ./Launcher.bin
+    ./Launcher.bin $1
and it started taking parameter as it should.

$@ is working as well.

My edited file in attachement.

Could you please fix this?

And little off-topic: Is commenting out 64bit version in run_steam.sh necessery? Because it seems it's running well. (enabled in my attached file) Also comment:
#  Steam claims they are going to put us in the app directory.
seems like forgotten.


Attached Files
.sh   run_steam.sh (Size: 322 bytes / Downloads: 59)
01-18-2013, 09:50 AM
Find
Your Computer Offline
SCAN ME!

Posts: 3,456
Threads: 32
Joined: Jul 2011
Reputation: 235
#2
Solved: 4 Years, 6 Months, 3 Weeks ago RE: Steam for Linux: Amnesia not taking launch options

If it works manually, then it's a Steam issue.

Tutorials: From Noob to Pro
01-18-2013, 10:42 AM
Website Find
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
#3
Solved: 4 Years, 6 Months, 3 Weeks ago RE: Steam for Linux: Amnesia not taking launch options

There were a few reports of issues running the 64bit version through steam so I had disabled it (since steam 4 linux is ONLY 32bit currently). Also, note there is NO steam overlay with 64bit either.

I've added "$@" to the launcher script so it'll accept launch arguments, and added a check for a file named "i_want_64".. simply touch that file and it'll force enabled 64bit for you.

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
01-18-2013, 02:26 PM
Website Find




Users browsing this thread: 1 Guest(s)