Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Collada in model editor won't appear
Xroph Offline
Junior Member

Posts: 32
Threads: 7
Joined: Sep 2013
Reputation: 1
#1
Collada in model editor won't appear

Hey :/

Since a few days I've got this big problem. I create a object with blender or maya, then I save it with the option "Triangulate" and "Use UV Textures", but if I import the mesh in the model editor, there is no object...

Please help Sad

11-01-2013, 07:38 PM
Website Find Reply
Kreekakon Offline
Pick a god and pray!

Posts: 3,063
Threads: 70
Joined: Mar 2012
Reputation: 124
#2
RE: Collada in model editor won't appear

Moved to correct section.

[Image: Tv0YgQb.gif]
Image by BandyGrass
11-01-2013, 08:13 PM
Find Reply
Acies Offline
Posting Freak

Posts: 1,643
Threads: 60
Joined: Feb 2011
Reputation: 73
#3
RE: Collada in model editor won't appear

Hmm... If it is 'invisible' there are a few potentials:
1) No triangulation
2) Two UV Maps assigned to the same mesh (two textures)
3) Is the pivot point at 0,0,0? Could potentially warp the mesh in scale and placement
4) A very large texture (2048) without mip maps
5) Might be a texture which isn't pow^2 (256^2, 512^2, 1024^2)


If it is stone textured:
1) The texture exported to amnesia has a different name than the texture assigned in your modeling program
2) Might be so that example 5 falls into this category

[Image: mZiYnxe.png]


11-01-2013, 08:42 PM
Find Reply
WALP Offline
Posting Freak

Posts: 1,221
Threads: 34
Joined: Aug 2012
Reputation: 45
#4
RE: Collada in model editor won't appear

I just leave this old copy-paste of mine here(this is for blender 2.6something btw):

"1. Your model must be triangulated(converted to triangles) before you export it.
Hold CTRL + F while in edit mode to make a menu with options for faces appear and click on the triangulate option
2.before exporting your model must have a blender internal render type material(so no cycles) assigned to it,just leave it at default for the material settings or perhaps tone down the spec if it gets annoying while editting. REMEMBER: only one material per object or crash.
3.Before exporting you model it must have a texture assigned to it, with UV cordinates. so make sure to set it to UV cordinates under mapping in the texture tab. only one texture per object as well.
4. make sure your object is at the center when you export. you can do that by first holding SHIFT + S and clicking cursor to center, and then doing the same but clicking selection to cursor instead.
This step is not necesary but your objects pivot point/origin will be at the center when exported to amnesia so it can get hard to work with if you dont do this step.
5. Apply scale rotation and location of your object by going to the apply menu by holding down CTRL + A and rest is self explanatory. this step is not necesary but it will prevent you model from being rotated, scaled or offset in amnesia.
6.Make sure your face normals are right before exporting or you will have what looks like holes in yout object in amnesia. If you click N to bring forth the navigation menu you will find an option called "Backface Culling" under display, this will only render the front of your objects faces just like in amnesia.
To fix a face that is facing the wrong way select it in edit mode, hit W to bring up the specials menu and click "flip normals".


EXPORT:
1.Go to file -> Export -> Collada (Default) (.dae)
2. find the desired location to export your model to. it must be within the amnesia folder.
3.Name your model, it is recommended that give its name an extension iconic to your CS/Mod so amnesia doesent mess up if someone has a mod with another object under the same name. Fx if you had a CS/Mod called banana attack with a chair you would name it chair_ba.dae, rather then chair.dae which would likely be messed up with another chair.
4.Before exporting there is some settings in the lower left corner I would like to go through:


Apply modifiers: applies your modifiers automatically, though I recommend doing everything manually before exporting since you cant always rely on these automatic feutures.


Selection Only: makes it so that only your selected objects are exported, I always use this option but you can work without it if you delete everything but what you are exporting from your scene. I like to have some lights around though so I find that unpractical.


Include Children: dunno exacly what this does but in terms of amnesia exporting this should always be unchecked.


Inlclude armatures: this is for exporting rigged models with skeletons, which are called armatures in blender. as far as I know no one has been able to export animated models from any other software then maya so I dont think you will ever need this option checked.


Inlcude Shape Keys: amnesia does not support shape keys only skeletons so this should be unchecked. mostly its not necesary to uncheck it though since mostly you wont even have any shape keys on you model.


Only Active UV layer:this should be unchecked


Include UV textures: this option is lethal, it will write what textures your model is using into the collada file, if you dont use this check box amnesia will likely crash.


Include material textures: uncheck this, amnesia is only UV textures.


Copy: Whether you are going to use this or not depends on where your textures are stored. if you have texture from outside the Amnesia/redist folder assigned to your model when exporting you should check this option. it will copy your textures to the location you are exporting to. if you already have your textures in the right location leave this unchecked.


Deform bones only: uncheck this


Export for second life: uncheck this


Use object indtances: not exacly 100% sure about this option but I have allways had it checked with no problems at all.


Sort by object name: always had this unchecked, but I dont know if it means anything. you can try and see for yourself if you feel experimental."
11-01-2013, 08:49 PM
Find Reply
Rapture Offline
Posting Freak

Posts: 1,078
Threads: 79
Joined: May 2011
Reputation: 30
#5
RE: Collada in model editor won't appear

I prefer to use the ModelView first (Others may skip the option) before I import it into the ModelEditor.
11-01-2013, 09:31 PM
Find Reply
Juras Offline
Member

Posts: 166
Threads: 2
Joined: Jul 2013
Reputation: 27
#6
RE: Collada in model editor won't appear

You have to check "include material textures" when you're exporting as a dae using blender. But if you're using maya I think it's called "use material textures" or something like that.

Co-Founder & Lead Art Director of Red Line Games
3D & Environment Artist, Animator
http://jurasbatas.deviantart.com
(This post was last modified: 11-01-2013, 09:41 PM by Juras.)
11-01-2013, 09:40 PM
Find Reply
Xroph Offline
Junior Member

Posts: 32
Threads: 7
Joined: Sep 2013
Reputation: 1
#7
RE: Collada in model editor won't appear

That won't work either.....I really don't know what I do wrong. I tried everything, I tested each option, I've done everything in the manual, but nothing happens... Sad

I think I make something wrong with the texture. In the model editor I can see the sphere without texture. I've used the right options, so maybe I have to try something else...

(This post was last modified: 11-02-2013, 11:12 AM by Xroph.)
11-02-2013, 10:58 AM
Website Find Reply
PutraenusAlivius Offline
Posting Freak

Posts: 4,713
Threads: 75
Joined: Dec 2012
Reputation: 119
#8
RE: Collada in model editor won't appear

The resolution of the image must be in powers of 2 like 256x256, 512x512, etc. It also must be in .dds format.

"Veni, vidi, vici."
"I came, I saw, I conquered."
11-02-2013, 12:21 PM
Find Reply
Xroph Offline
Junior Member

Posts: 32
Threads: 7
Joined: Sep 2013
Reputation: 1
#9
RE: Collada in model editor won't appear

It's an model. Not an texture. 3D object.

11-02-2013, 12:37 PM
Website Find Reply
Rapture Offline
Posting Freak

Posts: 1,078
Threads: 79
Joined: May 2011
Reputation: 30
#10
RE: Collada in model editor won't appear

Please post an image, your responses are getting confusing.
11-02-2013, 01:15 PM
Find Reply




Users browsing this thread: 1 Guest(s)