Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ATDD Demo Crashes
AFrayedKnot Offline
Junior Member

Posts: 2
Threads: 2
Joined: Jan 2014
Reputation: 0
#1
Solved: 3 Years, 9 Months, 1 Week ago ATDD Demo Crashes

I wanted to try the demo before purchasing the full game just to make sure that it ran on my computer alright. At first, it wouldn't even launch, but after following a couple of troubleshooting guides and making sure everything was up-to-date, I at least got as far as the launch screen. However even after messing with the options, the game immediately crashes after I try starting it. I tried looking again at troubleshooting, so forgive me if the answer or solution has already been addressed. I just couldn't find anything that sounded like the issue I have.

1) I have Windows 7, 64-bit, operating system.
2) It's a laptop.
3) hpl below

Version 1.10
-------- THE HPL ENGINE LOG ------------
Engine build ID 20100818114615

Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating generate module
Creating haptic module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating loader handlers
Creating resource managers
Adding loaders to handlers
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Init lowlevel graphics: 1280x720 bpp:32 fs:1 ms:0 gpufmt:2 cap:'Amnesia - The Dark Descent - Loading...' posSad-1x-1)
Setting video mode: 1280 x 720 - 32 bpp
Init Glew...OK
Setting up OpenGL
Vendor: Intel
Renderer: Intel® HD Graphics
Version: 2.1.0 - Build 8.15.10.2189
Max texture image units: 16
Max texture coord units: 8
Max user clip planes: 6
Two sided stencil: 1
Vertex Buffer Object: 1
Anisotropic filtering: 1
Max Anisotropic degree: 2
Multisampling: 1
Texture compression: 1
Texture compression S3TC: 1
Auto generate MipMaps: 1
Render to texture: 1
Max draw buffers: 8
Max color render targets: 8
Packed depth-stencil: 1
Texture float: 1
GLSL Version: 1.20 - Intel Build 8.15.10.2189
ShaderModel 2: 1
ShaderModel 3: 1
ShaderModel 4: 0
OGL ATIFragmentShader: 0
ATTENTION: System does not support const arrays in glsl!
Setting up G-Bugger: type: 0 texturenum: 3


Thanks in advance for any help or info you can give!

P.S. I'm going to include the launcher HPL Engine log as well since I found it. Don't know if it's what you want, but maybe it'll help. Thanks again!

-------- THE HPL ENGINE LOG ------------
Engine build ID 20100819012504

Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating generate module
Creating haptic module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating loader handlers
Creating resource managers
Adding loaders to handlers
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
--------------------------------------------------------

Initializing Sound Module
--------------------------------------------------------
Initializing OpenAL
Available OpenAL devices:
0. Generic Software on Speakers (Conexant SmartAudio HD)(OpenAL default)
Trying to open device 'Generic Software on Speakers (Conexant SmartAudio HD)'... Success!
Number of mono sources: 32
Streaming setup: 2 Buffers x 524288 bytes each
--------------------------------------------------------

Initializing Game Module
--------------------------------------------------------
Adding engine updates
Initializing script functions
--------------------------------------------------------

User Initialization
--------------------------------------------------------
--------------------------------------------------------

Exiting Gui Module
--------------------------------------------------------
Deleting all sets
Deleting all skins
Deleting all gfx elements
Deleting all materials
--------------------------------------------------------

Exiting Generate Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Scene Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Input Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Sound Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Graphics Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Resources Module
--------------------------------------------------------
Done with fonts
Done with scripts
Done with particles
Done with sounds
Done with meshes
Done with materials
Done with Gpu programs
Done with images
Destroyed all textures
Done with sound entities
Done with animations
Done with ent files
All resources deleted
--------------------------------------------------------

Exiting Physics Module
--------------------------------------------------------
--------------------------------------------------------

Exiting System Module
--------------------------------------------------------
--------------------------------------------------------

Deleting game setup provided by user
- Deleting lowlevel stuff.
Physics
Sound
Input
Resources
System
Graphics
Haptic
HPL Exit was successful!
01-21-2014, 01:54 AM
Find
jens Offline
Frictional Games

Posts: 4,093
Threads: 199
Joined: Apr 2006
Reputation: 202
#2
Solved: 3 Years, 9 Months, 1 Week ago RE: ATDD Demo Crashes

You have to update the driver for the graphics card by visiting intel.com and downloading from there.
01-21-2014, 08:30 AM
Website Find
plutomaniac Offline
Super Moderator

Posts: 6,368
Threads: 45
Joined: May 2011
Reputation: 183
#3
Solved: 3 Years, 9 Months, 1 Week ago RE: ATDD Demo Crashes

Thank you for following the troubleshooting guide and providing any relevant information asked there in advance. If the Intel setup Jens mentioned failed because of OEM issues etc, use the Have Disk Method as mentioned at the graphics card troubleshooting guide.
(This post was last modified: 01-21-2014, 11:44 AM by plutomaniac.)
01-21-2014, 11:41 AM
Find
AFrayedKnot Offline
Junior Member

Posts: 2
Threads: 2
Joined: Jan 2014
Reputation: 0
#4
Solved: 3 Years, 9 Months, 1 Week ago RE: ATDD Demo Crashes

Thank you, both, for helping me! I thought my drivers were updated, but after jumping through so many hoops, I managed to try the Have Disk Method and I got the game to run just fine. It's still pretty jerky when I play, but I can mess with the options on my own.
Also, toward the end of the Have Disk Method, it mentions selecting the "igdlh.inf" or "igdlh64.inf" programs. However, I couldn't find either of them in the driver update that I had downloaded. Instead, I chose what I thought to be the best alternative "kit51428". I know that I shouldn't just pick a program at random, but it was right there in graphics, and it was able to update just fine. I don't know if that's just different for me or what, but I thought it should be mentioned in case this needs to be mentioned in the Method guide.
01-22-2014, 12:27 AM
Find
plutomaniac Offline
Super Moderator

Posts: 6,368
Threads: 45
Joined: May 2011
Reputation: 183
#5
Solved: 3 Years, 9 Months, 1 Week ago RE: ATDD Demo Crashes

Glad it worked for you. Yeap the performance might not be optimal since Intel HD graphics cards are not supported. Some newer drivers seem to have changed the .inf file name to kitxxxxx instead. It's the same file we're talking about though so you did good. I'll add the kitxxxxx variation at the guide as well. Have fun playing the game.
(This post was last modified: 01-22-2014, 01:59 AM by plutomaniac.)
01-22-2014, 01:58 AM
Find




Users browsing this thread: 1 Guest(s)