Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help item crashing!
SSEAlexander Offline
Senior Member

Posts: 422
Threads: 26
Joined: Feb 2014
Reputation: 1
#1
Help item crashing!

im having problems! please help Angry
When i open model editor,import mesh and select any orginal item (tinderbox etc...)
then im changing settings of it(user variables)
but when i enter game,
Black box shows errors and game crashes.
When i check log,it does not say anything.
I want to make The thalers (bag of coins) changed to Puzzle items.

Can someone help?
03-16-2014, 08:20 PM
Find Reply
Romulator Offline
Not Tech Support ;-)

Posts: 3,623
Threads: 62
Joined: Jan 2013
Reputation: 195
#2
RE: Help item crashing!

Post your hpl.log file anyways after the error occurs, that's how you can fix errors.

Discord: Romulator#0001
[Image: 3f6f01a904.png]
03-16-2014, 09:30 PM
Find Reply
SSEAlexander Offline
Senior Member

Posts: 422
Threads: 26
Joined: Feb 2014
Reputation: 1
#3
RE: Help item crashing!

it doesnt say anything about it,

Version 1.20 - s26ADEE0-539
-------- THE HPL ENGINE LOG ------------
Engine build ID 20101021192547

Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating generate module
Creating haptic module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating loader handlers
Creating resource managers
Adding loaders to handlers
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Init lowlevel graphics: 640x480 bpp:32 fs:1 ms:0 gpufmt:2 cap:'Amnesia A Late Time In The Night Loading...' posSad-1x-1)
Setting video mode: 640 x 480 - 32 bpp
Init Glew...OK
Setting up OpenGL
Vendor: NVIDIA Corporation
Renderer: ION/integrated/SSE2
Version: 3.3.0
Max texture image units: 32
Max texture coord units: 8
Max user clip planes: 8
Two sided stencil: 1
Vertex Buffer Object: 1
Anisotropic filtering: 1
Max Anisotropic degree: 16
Multisampling: 1
Texture compression: 1
Texture compression S3TC: 1
Auto generate MipMaps: 1
Render to texture: 1
Max draw buffers: 8
Max color render targets: 8
Packed depth-stencil: 1
Texture float: 1
GLSL Version: 3.30 NVIDIA via Cg compiler
ShaderModel 2: 1
ShaderModel 3: 1
ShaderModel 4: 1
OGL ATIFragmentShader: 0
Setting up G-Bugger: type: 0 texturenum: 3
Adding engine materials
Initializing DevIL
Vendor String: Abysmal Software
Version String: Developer's Image Library (DevIL) 1.6.8pre Aug 12 2006
Version Number: 168
Adding engine post effects
--------------------------------------------------------

Initializing Sound Module
--------------------------------------------------------
Initializing OpenAL
Available OpenAL devices:
0. Generic Software on Speakers (Realtek High Definition Audio)(OpenAL default)
1. Generic Software on Realtek Digital Output (Realtek High Definition Audio)
Trying to open device 'Generic Software on Speakers (Realtek High Definition Audio)'... Success!
Number of mono sources: 32
Streaming setup: 4 Buffers x 262144 bytes each
--------------------------------------------------------

Initializing Game Module
--------------------------------------------------------
Adding engine updates
Initializing script functions
--------------------------------------------------------

User Initialization
--------------------------------------------------------
ERROR: Couldn't load language file 'ALTITN/config/base_english.lang'
--------------------------------------------------------

Game Running
--------------------------------------------------------
-------- Loading map 'menu_bg.map' ---------
ERROR: Could not open binary file 'D:/Program Files (x86)/Amnesia - The Dark Descent/redist/ALTITN/main_menu/menu_bg.map_cache'
ERROR: Could not map cache file 'D:/Program Files (x86)/Amnesia - The Dark Descent/redist/ALTITN/main_menu/menu_bg.map'.ERROR: Couldn't find 0-face '../../../../_pos_x', for cubemap '../../../../' in path: '../../../../'
MeshEntity Loading: 782 ms
Primitive Loading: 105 ms
Decal Loading: 0 ms
Object Combining: 0 ms
Compilation: 1 ms
Combining: 455 ms
Sorting: 229 ms
Meshes: 5 ms
Bodies: 221 ms
Static Objects: 1344 ms
Entities: 2174 ms
Compilation: 1 ms
Total: 3528 ms
Meshes created: 6
Bodies created: 3
-------- Loading complete ---------
ERROR: Couldn't create SoundEntity 'valve_iron_rusty_move.snt'
ERROR: Cannot find sound entity 'valve_iron_rusty_move'
ERROR: Couldn't create SoundEntity 'valve_iron_rusty_move.snt'
ERROR: Cannot find sound entity 'valve_iron_rusty_move'
ERROR: Couldn't create SoundEntity 'valve_iron_rusty_move.snt'
ERROR: Cannot find sound entity 'valve_iron_rusty_move'
ERROR: Couldn't create SoundEntity 'valve_iron_rusty_move.snt'
ERROR: Cannot find sound entity 'valve_iron_rusty_move'
ERROR: Couldn't create SoundEntity 'valve_iron_rusty_move.snt'
ERROR: Cannot find sound entity 'valve_iron_rusty_move'
ERROR: Couldn't create SoundEntity 'valve_iron_rusty_move.snt'
ERROR: Cannot find sound entity 'valve_iron_rusty_move'
ERROR: Couldn't create SoundEntity 'valve_iron_rusty_move.snt'
ERROR: Cannot find sound entity 'valve_iron_rusty_move'
Setting profile: 'stenclowski-ALT' Path: 'C:\Users\msi\Documents/Amnesia/Main/stenclowski-ALT/'
ERROR: Couldn't create script 'ALTITN/maps/global.hps'
ERROR: Global script 'ALTITN/maps/global.hps' could not be created!
-------- Loading map '03_Help.map' ---------
ERROR: Could not open binary file 'D:/Program Files (x86)/Amnesia - The Dark Descent/redist/ALTITN/maps/03_Help.map_cache'
ERROR: Could not map cache file 'D:/Program Files (x86)/Amnesia - The Dark Descent/redist/ALTITN/maps/03_Help.map'.ERROR: Couldn't find 0-face '../../../../_pos_x', for cubemap '../../../../' in path: '../../../../'
MeshEntity Loading: 296 ms
Primitive Loading: 62 ms
Decal Loading: 0 ms
Object Combining: 0 ms
Compilation: 1 ms
Combining: 56 ms
Sorting: 54 ms
Meshes: 2 ms
Bodies: 0 ms
Static Objects: 416 ms
Entities: 596 ms
Compilation: 0 ms
Total: 1018 ms
Meshes created: 3
Bodies created: 2
-------- Loading complete ---------
WARNING: Could not find player start node 'PlayerStartArea_2'
ERROR: StartPos 'PlayerStartArea_2' does not exist!
ERROR: Couldn't create script 'ALTITN/maps/inventory.hps'
ERROR: Inventory script 'ALTITN/maps/inventory.hps' not found!
03-16-2014, 10:07 PM
Find Reply
DnALANGE Offline
Banned

Posts: 1,549
Threads: 73
Joined: Jan 2012
#4
RE: Help item crashing!

I want to make The thalers (bag of coins) changed to Puzzle items.
-
Will NOT work without a FULL CONVERSION! hope you are making a FC.
IF you change some things in the modeleditor, and doing it wrong the game could crash yeah.
KNOW what youa re doing here.
03-16-2014, 10:31 PM
Find Reply
Mudbill Offline
Muderator

Posts: 3,838
Threads: 59
Joined: Apr 2013
Reputation: 177
#5
RE: Help item crashing!

Why would this only work for a full conversion mod? Of course it works with custom stories. It's nothing more than a custom entity.
It's a very simple thing to do, but the problem here is not how to do it. I've seen errors similar to these in other threads, but I don't know exactly what was done in order to fix it, I'm afraid.

03-17-2014, 12:04 AM
Find Reply
Romulator Offline
Not Tech Support ;-)

Posts: 3,623
Threads: 62
Joined: Jan 2013
Reputation: 195
#6
RE: Help item crashing!

Quote:WARNING: Could not find player start node 'PlayerStartArea_2'
ERROR: StartPos 'PlayerStartArea_2' does not exist!

Have you not indicated a PlayerStartArea in your map, or done so incorrectly in the Level Editor transitioning from one map to the next?

Also, as far as I know, you don't need to change thalers in the model editor, but you need to do something specific to get them to work in Amnesia, such as making global variables to figuring out how many thalers you have, boxes which require thalers, etc.

Discord: Romulator#0001
[Image: 3f6f01a904.png]
03-17-2014, 09:07 AM
Find Reply
SSEAlexander Offline
Senior Member

Posts: 422
Threads: 26
Joined: Feb 2014
Reputation: 1
#7
RE: Help item crashing!

i tried everything. I was going to make another mods. My plans :
Penumbra Apocalypse (Cancelled)
Amnesia ALTITN (Devolpment)
SCP : Hazardous (Recreation of SCP : CB on Amnesia with diffrent story)
Unknown Recreation (Recreation of Amnesia - Early Alpha [With these thalers features,etc...)
03-17-2014, 04:38 PM
Find Reply
PutraenusAlivius Offline
Posting Freak

Posts: 4,713
Threads: 75
Joined: Dec 2012
Reputation: 119
#8
RE: Help item crashing!

(03-17-2014, 04:38 PM)stenclowskimat Wrote: i tried everything. I was going to make another mods. My plans :
Penumbra Apocalypse (Cancelled)
Amnesia ALTITN (Devolpment)
SCP : Hazardous (Recreation of SCP : CB on Amnesia with diffrent story)
Unknown Recreation (Recreation of Amnesia - Early Alpha [With these thalers features,etc...)

It's better to just develop and throughly plan 1 idea for a CS than thinking of 2.

"Veni, vidi, vici."
"I came, I saw, I conquered."
03-18-2014, 01:21 AM
Find Reply
Traggey Offline
is mildly amused

Posts: 3,256
Threads: 73
Joined: Feb 2012
Reputation: 185
#9
RE: Help item crashing!

Dude... You KEEP posting these in the WRONG section of the forums! Stop it man!

Moved to development support.
03-21-2014, 05:08 PM
Find Reply
SSEAlexander Offline
Senior Member

Posts: 422
Threads: 26
Joined: Feb 2014
Reputation: 1
#10
RE: Help item crashing!

(03-21-2014, 05:08 PM)Traggey Wrote: Dude... You KEEP posting these in the WRONG section of the forums! Stop it man!

Moved to development support.
daah sory.I already solved the problem anyways.
03-28-2014, 03:08 PM
Find Reply




Users browsing this thread: 1 Guest(s)