Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Level Editor Help Could not load XML document '../../../../'
CarnivorousJelly Offline
Posting Freak

Posts: 1,196
Threads: 41
Joined: Dec 2012
Reputation: 80
#1
Could not load XML document '../../../../'

So I'm working on a map with another person and we've been transferring it over skype. On my computer, both Amnesia and the level editor crash every time I try to open the map, but it works just fine on his and his friend's computer (so I think it must be a problem with mine).

The log for the level editor looks like this:
(the bottom part's where the error is)
-------- THE HPL ENGINE LOG ------------
Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating generate module
Creating haptic module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating loader handlers
Creating resource managers
Adding loaders to handlers
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Init lowlevel graphics: 1366x758 bpp:32 fs:0 ms:0 gpufmt:2 cap:'HPL Level Editor' pos:(-1x-1)
Setting video mode: 1366 x 758 - 32 bpp
Init Glew...OK
Setting up OpenGL
  Vendor: NVIDIA Corporation
  Renderer: Quadro FX 880M/PCI/SSE2
  Version: 3.3.0
  Max texture image units: 32
  Max texture coord units: 8
  Max user clip planes: 6
  Two sided stencil: 1
  Vertex Buffer Object: 1
  Anisotropic filtering: 1
  Max Anisotropic degree: 16
  Multisampling: 1
  Texture compression: 1
  Texture compression S3TC: 1
  Auto generate MipMaps: 1
  Render to texture: 1
  Max draw buffers: 8
  Max color render targets: 8
  Packed depth-stencil: 1
  Texture float: 1
  GLSL Version: 3.30 NVIDIA via Cg compiler
  ShaderModel 2: 1
  ShaderModel 3: 1
  ShaderModel 4: 1
  OGL ATIFragmentShader: 0
Setting up G-Bugger: type: 0 texturenum: 4
Adding engine materials
Initializing DevIL
  Vendor String: Abysmal Software
  Version String: Developer's Image Library (DevIL) 1.6.8pre Aug 12 2006
  Version Number: 168
Adding engine post effects
--------------------------------------------------------

Initializing Sound Module
--------------------------------------------------------
Initializing OpenAL
  Available OpenAL devices:
   0. Generic Software on Speakers (Conexant 20585 SmartAudio HD)(OpenAL default)
  Trying to open device 'Generic Software on Speakers (Conexant 20585 SmartAudio HD)'... Success!
  Number of mono sources: 32
  Streaming setup: 2 Buffers x 524288 bytes each
--------------------------------------------------------

Initializing Game Module
--------------------------------------------------------
Adding engine updates
Initializing script functions
--------------------------------------------------------

User Initialization
--------------------------------------------------------
-----------------------------------------------------
LevelEditor Build ID: 20101027185544
-----------------------------------------------------
Created Entity Loader
Added object type: Compound <Compound>
Added object type: Light <BoxLight>
Added object type: Light <PointLight>
Added object type: Light <SpotLight>
Added object type: Billboard <Billboard>
Added object type: Particle System <ParticleSystem>
Added object type: Sound <Sound>
Added object type: Static Object <StaticObject>
Added object type: Entity <Entity> StaticProp
Added object type: Entity <Entity> CommentaryIcon
Added object type: Entity <Entity> Object,Static
Added object type: Entity <Entity> Object,Grab
Added object type: Entity <Entity> Object,Push
Added object type: Entity <Entity> Object,Slide
Added object type: Entity <Entity> SwingDoor
Added object type: Entity <Entity> Lever
Added object type: Entity <Entity> Wheel
Added object type: Entity <Entity> MultiSlider
Added object type: Entity <Entity> Lamp
Added object type: Entity <Entity> Button
Added object type: Entity <Entity> Photocell
Added object type: Entity <Entity> MoveObject
Added object type: Entity <Entity> Item,Puzzle
Added object type: Entity <Entity> Item,Coins
Added object type: Entity <Entity> Item,Note
Added object type: Entity <Entity> Item,Diary
Added object type: Entity <Entity> Item,Lantern
Added object type: Entity <Entity> Item,Health
Added object type: Entity <Entity> Item,Sanity
Added object type: Entity <Entity> Item,LampOil
Added object type: Entity <Entity> Item,Tinderbox
Added object type: Entity <Entity> Item,HandObject
Added object type: Entity <Entity> Chest
Added object type: Entity <Entity> OilBarrel
Added object type: Entity <Entity> EmotionStone
Added object type: Entity <Entity> NPC
Added object type: Entity <Entity> LevelDoor
Added object type: Entity <Entity> CritterBug
Added object type: Entity <Entity> CritterSpider
Added object type: Entity <Entity> Enemy_Grunt
Added object type: Entity <Entity> Enemy_ManPig
Added object type: Entity <Entity> Enemy_WaterLurker
Added object type: Entity <Entity> PlayerHands
Added object type: Entity <Entity> HandObject
Added object type: Area <Area> Script
Added object type: Area <Area> PosNode
Added object type: Area <Area> Flashback
Added object type: Area <Area> Sign
Added object type: Area <Area> SlimeDamage
Added object type: Area <Area> Examine
Added object type: Area <Area> Insanity
Added object type: Area <Area> Ladder
Added object type: Area <Area> Liquid
Added object type: Area <Area> Sticky
Added object type: Area <Area> Rope
Added object type: Area <Area> PathNode
Added object type: Area <Area> PlayerStart
Added object type: Primitive <Plane>
Added object type: Decal <Decal>
Added object type: FogArea <FogArea>

/////////////////////////////////////////////////////////////////
// Resetting scene
/////////////////////////////////////////////////////////////////

--------------------------------------------------------

Game Running
--------------------------------------------------------

/////////////////////////////////////////////////////////////////
// Resetting scene
/////////////////////////////////////////////////////////////////


/////////////////////////////////////////////////////////////////
// Loading file C:/Users/Emily/Desktop/Tesla.map
/////////////////////////////////////////////////////////////////

ERROR: Could not load XML document '../../../../'
ERROR: Could not load XML document '../../../../'
ERROR: Could not load XML document '../../../../'
ERROR: Could not load XML document '../../../../'
ERROR: Could not load XML document '../../../../'
ERROR: Could not load XML document '../../../../'
ERROR: Could not load XML document '../../../../'
ERROR: Could not load XML document '../../../../'
ERROR: Could not load XML document '../../../../'
ERROR: Could not load XML document '../../../../'
ERROR: Could not load XML document '../../../../'
ERROR: Could not load XML document '../../../../'
ERROR: Could not load XML document '../../../../'
ERROR: Could not load XML document '../../../../'
ERROR: Could not load XML document '../../../../'
ERROR: Could not load XML document '../../../../'
ERROR: Could not load XML document '../../../../'
ERROR: Could not load XML document '../../../../'
ERROR: Could not load XML document '../../../../'
ERROR: Could not load XML document '../../../../'
ERROR: Could not load XML document '../../../../'
ERROR: Could not load XML document '../../../../'
Error creating Entity named elevator_switch_1, ID 1527
ERROR: Could not load XML document ''

We've tried deleting certain entities to see if those were the problems, but the error is still showing up. I can open the map in notepad and look at the script, but that's it. Any suggestions about what's wrong?

Thanks for any help c:

Edit: should it also be of note, this is Amnesia's log when I tried to run the map in-game
Version 1.20
-------- THE HPL ENGINE LOG ------------
Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating generate module
Creating haptic module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating loader handlers
Creating resource managers
Adding loaders to handlers
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Init lowlevel graphics: 1366x768 bpp:32 fs:0 ms:0 gpufmt:2 cap:'Amnesia - The Dark Descent - Loading...' pos:(-1x-1)
Setting video mode: 1366 x 768 - 32 bpp
Init Glew...OK
Setting up OpenGL
  Vendor: NVIDIA Corporation
  Renderer: Quadro FX 880M/PCI/SSE2
  Version: 3.3.0
  Max texture image units: 32
  Max texture coord units: 8
  Max user clip planes: 6
  Two sided stencil: 1
  Vertex Buffer Object: 1
  Anisotropic filtering: 1
  Max Anisotropic degree: 16
  Multisampling: 1
  Texture compression: 1
  Texture compression S3TC: 1
  Auto generate MipMaps: 1
  Render to texture: 1
  Max draw buffers: 8
  Max color render targets: 8
  Packed depth-stencil: 1
  Texture float: 1
  GLSL Version: 3.30 NVIDIA via Cg compiler
  ShaderModel 2: 1
  ShaderModel 3: 1
  ShaderModel 4: 1
  OGL ATIFragmentShader: 0
Setting up G-Bugger: type: 0 texturenum: 3
Adding engine materials
Initializing DevIL
  Vendor String: Abysmal Software
  Version String: Developer's Image Library (DevIL) 1.6.8pre Aug 12 2006
  Version Number: 168
Adding engine post effects
--------------------------------------------------------

Initializing Sound Module
--------------------------------------------------------
Initializing OpenAL
  Available OpenAL devices:
   0. Generic Software on Speakers (Conexant 20585 SmartAudio HD)(OpenAL default)
  Trying to open device 'Generic Software on Speakers (Conexant 20585 SmartAudio HD)'... Success!
  Number of mono sources: 32
  Streaming setup: 4 Buffers x 262144 bytes each
--------------------------------------------------------

Initializing Game Module
--------------------------------------------------------
Adding engine updates
Initializing script functions
--------------------------------------------------------

User Initialization
--------------------------------------------------------
-------- Loading map 'menu_bg.map' ---------
    Cache Loading: 1119 ms
ERROR: Couldn't find 0-face '../../../../_pos_x', for cubemap '../../../../' in path: '../../../../'
  Entities: 248 ms
  Compilation: 5 ms
  Total: 1414 ms
  Meshes created: 31
  Bodies created: 28
-------- Loading complete ---------
--------------------------------------------------------

Game Running
--------------------------------------------------------
Setting profile: 'DevProfile' Path: 'C:\Users\Emily\Documents/Amnesia/Main/DevProfile/'
-------- BEGIN LOAD FROM C:\Users\Emily\Documents/Amnesia/Main/DevProfile/AutoSave_MachineRoom_2014_4_13_19_56_27_0.sav ---------
LOADING SAVE GAME!
-------- Loading map '13_machine_room.map' ---------
    Cache Loading: 912 ms
  Entities: 885 ms
  Compilation: 23 ms
  Total: 1943 ms
  Meshes created: 104
  Bodies created: 35
-------- Loading complete ---------
WARNING: Could not find player start node ''
ERROR: StartPos '' does not exist!
-------- END LOAD ---------
-------- Debug window open!
ERROR: Script file maps/main/Tesla.hps does not exist!
-------- Loading map 'Tesla.map' ---------
ERROR: Couldn't find 0-face '../../../../../../_pos_x', for cubemap '../../../../../../' in path: '../../../../../../'
    MeshEntity Loading: 2045 ms
    Primitive Loading: 0 ms
    Decal Loading: 0 ms
    Object Combining: 0 ms
    Compilation: 52 ms
    Combining: 949 ms
     Sorting: 85 ms
     Meshes: 50 ms
     Bodies: 814 ms
  Static Objects: 3049 ms
ERROR: Couldn't create ent file 'entities/elevator/elevator_switch.ent'
WARNING: Sub mesh 'gauge014' does not exist in mesh 'gauge03.msh'!
WARNING: Sub mesh 'Object334' does not exist in mesh 'gauge03.msh'!
WARNING: Could not find child with unique ID 0 to attach to entity 'gauge03_1_Body_1' in 'entities/gauges/gauge03.ent'
WARNING: Could not find child with unique ID 1 to attach to entity 'gauge03_1_Body_1' in 'entities/gauges/gauge03.ent'
WARNING: Sub mesh 'gauge014' does not exist in mesh 'gauge03.msh'!
WARNING: Sub mesh 'Object334' does not exist in mesh 'gauge03.msh'!
WARNING: Could not find child with unique ID 0 to attach to entity 'gauge03_2_Body_1' in 'entities/gauges/gauge03.ent'
WARNING: Could not find child with unique ID 1 to attach to entity 'gauge03_2_Body_1' in 'entities/gauges/gauge03.ent'
WARNING: Sub mesh 'gauge014' does not exist in mesh 'gauge03.msh'!
WARNING: Sub mesh 'Object334' does not exist in mesh 'gauge03.msh'!
WARNING: Could not find child with unique ID 0 to attach to entity 'gauge03_3_Body_1' in 'entities/gauges/gauge03.ent'
WARNING: Could not find child with unique ID 1 to attach to entity 'gauge03_3_Body_1' in 'entities/gauges/gauge03.ent'
  Entities: 460 ms
  Compilation: 5 ms
Saving cache file for 'C:/Program Files (x86)/Amnesia - The Dark Descent/redist/custom_stories/Xander's CS/Tesla.map'
  Total: 3568 ms
  Meshes created: 91
  Bodies created: 28
-------- Loading complete ---------

[Image: quote_by_rueppells_fox-d9ciupp.png]
(This post was last modified: 04-17-2014, 06:48 AM by CarnivorousJelly.)
04-17-2014, 06:34 AM
Find Reply
Romulator Offline
Not Tech Support ;-)

Posts: 3,626
Threads: 62
Joined: Jan 2013
Reputation: 195
#2
RE: Could not load XML document '../../../../'

Right now, it looks to be a problem with an entity called "elevator_switch" or "elevator_switch_1". Have you tried removing that?

Is there any differences between your editors? Like, is one person using 131111 and the other using the original?

Discord: Romulator#0001
[Image: 3f6f01a904.png]
(This post was last modified: 04-17-2014, 10:07 AM by Romulator.)
04-17-2014, 10:06 AM
Find Reply
Mudbill Offline
Muderator

Posts: 3,877
Threads: 59
Joined: Apr 2013
Reputation: 178
#3
RE: Could not load XML document '../../../../'

It mentions gauges a lot, which makes me believe you have the Machine for Pigs assets added? Did you both add them the same way? Perhaps a slight difference causes the entity of one of you to not match the entity of the other. If you have those, I'm gonna assume you also have the 131111 patch.
I think the XML document it's referring to is simply the map, cause it's written as such. As Rom said, try to investigate the elevator_switch.ent as well.

04-17-2014, 04:02 PM
Find Reply
Romulator Offline
Not Tech Support ;-)

Posts: 3,626
Threads: 62
Joined: Jan 2013
Reputation: 195
#4
RE: Could not load XML document '../../../../'

Actually, ANOTHER possibility:

I was working with models last night, and while I'm assuming that this is not exactly the problem, but the directory for the elevator_switch's mesh may differ between you and your friend Smile

Discord: Romulator#0001
[Image: 3f6f01a904.png]
04-18-2014, 03:09 AM
Find Reply
Xander512 Offline
Junior Member

Posts: 32
Threads: 4
Joined: Sep 2013
Reputation: 0
#5
RE: Could not load XML document '../../../../'

We fixed the problem, guys. Thanks for your advice! Turns out Kia just transferred some AMFP filed improperly Tongue
04-18-2014, 03:47 AM
Find Reply




Users browsing this thread: 1 Guest(s)