Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Whole Penumbra Series: Multiple Problems
bmeeker625 Offline
Junior Member

Posts: 1
Threads: 1
Joined: Jun 2014
Reputation: 0
#1
Solved: 3 Years, 5 Months, 3 Weeks ago Whole Penumbra Series: Multiple Problems

Hi,

I've wanted to play my newly bought penumbra series for a while know, I bought it off steam for $10, all of them, and they have worked once or twice before, but I wanted to play them today, but to no avail, it did not work. Penumbra Overture and Black Plague just crashed on start up, and when I started requiem, it was an entire different story. My computer's contrast went up, and there is a buzzing sound coming from the speakers on my TV coming from the computer (Not the TV because I've tried turning on my PS3 on the same channel, and it didn't make the buzzing noise, and the contrast is normal.) I've tried restarting my computer, doesn't work, tried changing my Playback devices, still didn't work.

Windows 8 64 bit
Desktop

Requiem:
-------- THE HPL ENGINE LOG ------------

Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating haptic module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating resource managers
Misc Creation
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Init low level graphics
Setting video mode: 1600 x 1200 - 32 bpp
ERROR: Could not set display mode setting a lower one!
Init Glee...OK
Setting up OpenGL
  Max texture image units: 16
  Max texture coord units: 16
  Two sided stencil: 1
  Vertex Buffer Object: 1
  Anisotropic filtering: 1
  Max Anisotropic degree: 16
  Multisampling: 1
  Vertex Program: 1
  Fragment Program: 1
  NV Register Combiners: 0
  NV Register Combiners Stages: 11
  ATI Fragment Shader: 1
Creating graphic systems
  Creating Renderer2D
  Renderer2D created
  Creating Renderer3D
   Load Renderer3D gpu programs:
    Extrude
    Diffuse Vertex
    Diffuse Fragment
    Fog
   Creating fog textures: Solid Additive Alpha
   init sky box
  Renderer3D created
Creating screen buffers size 640.000000 : 480.000000
Creating programs
CG ERROR : The compile returned an error.
-----------------------------------
core/programs/PostEffect_Motion_fp.cg(32) : error C5013: profile does not support "for" statements and "for" could not be unrolled.
-----------------------------------
CG: Error loading: 'core/programs/PostEffect_Motion_fp.cg'!
ERROR: Couldn't create program 'PostEffect_Motion_fp.cg'
Dynamic loops in motion blur fp not supported, loading static instead.
  RendererPostEffects created
Adding engine materials
--------------------------------------------------------

Initializing Sound Module
--------------------------------------------------------
Initializing OpenAL.
  Trying to open software device... Success!
  Device name: Generic Software Compatibility Mode
  Number of mono sources: 32
--------------------------------------------------------

Initializing Game Module
--------------------------------------------------------
Adding engine updates
Initializing script functions
--------------------------------------------------------

User Initialization
--------------------------------------------------------
Initializing Penumbra: Black Plague
  Version    $Rev: 2595 $
  Date    $Date: 2008-05-03 15:09:49 +0200 (lö, 03 maj 2008) $
Checking Supported Profiles
  Profile CG_PROFILE_ARBVP1 is supported
  Profile CG_PROFILE_ARBFP1 is supported
  Profile CG_PROFILE_GLSLV is supported
  Profile CG_PROFILE_GLSLF is supported
  Profile CG_PROFILE_GLSLC is supported
Trying to load vertex program!
Success!
WARNING: Could not find language file entry 'PreMenuText'
All set up done, starting game!
--------------------------------------------------------
Then crash, and the buzzing, and the contrast change happened.

Black Plague:
-------- THE HPL ENGINE LOG ------------

Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating haptic module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating resource managers
Misc Creation
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Init low level graphics
Setting video mode: 1440 x 900 - 32 bpp
Init Glee...OK
Then crash

Overture:
-------- THE HPL ENGINE LOG ------------

Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating haptic module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating resource managers
Misc Creation
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Init low level graphics
Setting video mode: 800 x 600 - 32 bpp
Init Glee...OK
Then crash

I have tried reinstalling, but the same thing happens.

My graphics drivers and OpenGL is all up to date.

So I've fixed the contrast and the buzzing issue, but none of the penumbra games will run still.
(This post was last modified: 06-03-2014, 02:16 AM by bmeeker625.)
06-03-2014, 01:58 AM
Find
plutomaniac Offline
Super Moderator

Posts: 6,368
Threads: 45
Joined: May 2011
Reputation: 183
#2
Solved: 3 Years, 5 Months, 3 Weeks ago RE: Whole Penumbra Series: Multiple Problems

My best guess would be graphics card drivers issues. Can you try the Amnesia demo and see if that works? If it doesn't attach it's HPL.log (Documents\Amnesia\Main).
(This post was last modified: 06-03-2014, 11:19 AM by plutomaniac.)
06-03-2014, 11:18 AM
Find




Users browsing this thread: 1 Guest(s)