Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HPL Editor 1.3 on Mac and GNU/Linux
Adrien2002 Offline
Junior Member

Posts: 16
Threads: 5
Joined: May 2012
Reputation: 0
#1
Solved: 2 Years, 9 Months, 1 Week ago HPL Editor 1.3 on Mac and GNU/Linux

Why does the HPL Editor updated only for Windows ? What about GNU/Linux and Mac users ?

I was working on a custom story 100 % made in Linux but now I can not because the version is different and I don't want to use Wine if the game is native on Linux !

And could you correct the crash when choosing entities and the problem with the sound entity not working with Linux ?

To explain you better how to do to be able to use the HPL Editor again after a crash with Linux, I must do this :

exec rm -rf /home/adrien2002/.frictionalgames/HPL2/Temp /home/adrien2002/.frictionalgames/HPL2/Thumbnails /home/adrien2002/.frictionalgames/HPL2/LevelEditor.log && echo "<Screen Width="1914.00000000000000000000" Height="1032.00000000000000000000" Fullscreen="" TexQuality="0" />" > /home/adrien2002/.frictionalgames/HPL2/LevelEditor.cfg && sleep 3 && /home/adrien2002/Programmes/Amnesia/LevelEditor.bin64

To delete all config files of the editor and re-write a new config file with the correct resolution to be able to use it again directly with the right resolution.

If I don't do that, next time I will start the HPL Editor, the thumbnails won't appear and the crash will come quicker.

This is a known bug, this is absolutely NOT because of my distribution or because of me, I have this bug on many computers and every Linux distribution I tried.

The sound problem is something different : If I want to set a rain sound, I must put the sound entity, save and go to the map location, open it with a text editor, find the line about Sound_1 (for example) and add the path of the sound between "" because when I choose one with the HPL Editor, it never works, the sound is NOT set, it stays blank.

Could you update and fix those problems ? They are the only problems I had with it, after hours and hours and hours of use, those two problems are the only I found out.

A big fan, Adrien.

PS : Please don't ignore me, I am not the only one who play Amnesia on GNU/Linux and I am not the only one to complaint about those problems. If you really think about players, please fix it, for us
01-21-2015, 08:55 AM
Find
Mudbill Offline
Muderator

Posts: 3,733
Threads: 59
Joined: Apr 2013
Reputation: 173
#2
Solved: 2 Years, 9 Months, 1 Week ago RE: HPL Editor 1.3 on Mac and GNU/Linux

I believe the sound issue you're describing is present on Mac as well. I wouldn't know though, since the editors haven't worked since 1.3 was released, but it was at least there in 1.2.

03-09-2015, 04:23 PM
Find




Users browsing this thread: 1 Guest(s)