Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee

No audio, no errors (1.1 Collection)

Solved: 2 Years, 3 Months, 3 Weeks ago No audio, no errors (1.1 Collection)
The subject says the story, basically. Sound does not work, on intro, menu, or game. There are no errors in hpl.log, it just says it opened the sound device successfully and lists the possible devices, etc.

My audio setup is a little odd, so here goes. The game runs on a computer, which is connected via HDMI to my TV. The TV then sends the HDMI audio signal to an AVR via an optical line, and the AVR plays it to my speakers. From the game's perspective, it just needs to play audio to the HDMI device (hw:0,3) and ALSA should take care of the rest. I have no idea why it isn't working.

Again, I am running the collection, though I've not tried anything but Overture, as I still can't get it working long enough to finish it. The collection is patched to 1.1. I removed the libs from the game's directory, per instructions I found on this forum, so it is using the system's native libvorbis, libogg and openal libraries. I am running Gentoo.

And just for the sake of completeness, audio works for other programs, though I don't know that they use openal, so it's not ALSA's fauilt. I am not using PulseAudio.
06-12-2010, 06:25 PM
Jump to the post that solved this thread.

Users browsing this thread: 1 Guest(s)