Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
DGA Mouse and shadows
zevv Offline
Junior Member

Posts: 11
Threads: 3
Joined: Jun 2010
Reputation: 0
#1
Solved: 3 Years, 8 Months, 1 Week ago DGA Mouse and shadows

Game runs pretty well on my Linux debian, Nvidia Quadro NVS 140M. Framerate is not to high, but setting resolution to 800x600 is very playable.

Two issues i've run into:

- Mouse jumps around, same as in penumbra. Can be fixed by setting the environment variable SDL_VIDEO_X11_DGAMOUSE to '0'

- Casted light shows weird effects. The effect can be seen in the room where with the crack in the ceiling where the light shines through, and the boxes stacked to the wall. I guess both are suppost to cast light, but instead all objectes which should be affected by this light are painted green/blueish, flashing hue when I'm moving around. Setting 'shadows' to 'off' in graphics solves this, but alas, no shadows then.

Thanks for the great demo so far!
09-03-2010, 09:24 PM
Find
Romme Offline
Junior Member

Posts: 1
Threads: 0
Joined: Sep 2010
Reputation: 0
#2
Solved: 3 Years, 8 Months, 1 Week ago RE: DGA Mouse and shadows

Installing the latest nvidia drivers (256.53) solved the shadow problems for me.
09-04-2010, 07:25 PM
Find
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
#3
Solved: 3 Years, 8 Months, 1 Week ago RE: DGA Mouse and shadows

What version of X are you running that causes the DGA mouse issue?

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
09-05-2010, 12:54 PM
Website Find
zevv Offline
Junior Member

Posts: 11
Threads: 3
Joined: Jun 2010
Reputation: 0
#4
Solved: 3 Years, 8 Months, 1 Week ago RE: DGA Mouse and shadows

Running Xorg 1.7.7. The mouse problem occurs on all versions of penumbra as well, but I have never experienced it in any other SDL application, so it seems to be specific to something in the Frictional code.

The 'light' problem can be solved by setting the shadow quality to 'medium', I will try later to update my nvidia drivers to see if this fixes things as well.

No other complains, the game seems to work just fine, and performs good enough on my 3 year old nvidia!
(This post was last modified: 09-05-2010, 02:12 PM by zevv.)
09-05-2010, 02:12 PM
Find
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
#5
Solved: 3 Years, 8 Months, 1 Week ago RE: DGA Mouse and shadows

Very strange. I'm running Xorg 1.8.2 running a almost 5 year old Nvidia card and have yet to encounter that.

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
09-05-2010, 02:14 PM
Website Find




Users browsing this thread: 1 Guest(s)