Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Crash after starting and picking up a few items
megadonkey
Unregistered

 
#1
Solved: 2 Years, 6 Months, 3 Weeks ago Crash after starting and picking up a few items
I'm experiencing segfaults right after I start a new game (or continue one after a crash). It seems to happen on clicking to interact with an item; sometimes before that I can click maybe one or two that are fine.
I've verified the install several times, tried the non-steam binary, a public beta, fiddled around with removing and putting back libs, even reinstalled Steam, but it still crashes every time.
I have no trouble running other 3D games on this system (Debian Testing on a laptop with a GTX 660M, proprietary NVidia driver 352.79-1), such as The Talos Principle and Metro: Last Light.
Anyway I've been trying to get this game to work since last night, it's 6am and I'm close to tears. What now?
Attached ~/.local/share/frictionalgames/Soma/Main/hpl.log


Attached Files
.log   hpl.log (Size: 19.82 KB / Downloads: 19)
02-11-2016, 09:14 PM
Romulator Offline
Not Tech Support ;-)

Posts: 3,577
Threads: 61
Joined: Jan 2013
Reputation: 193
#2
Solved: 2 Years, 6 Months, 3 Weeks ago RE: Crash after starting and picking up a few items
Your version of OpenGL is 3.2.0, where SOMA's minimum is 3.3.0.

Have you checked for any updates for your graphics card? Since you're using an nVidia, you should be able to check here: http://www.nvidia.com/Download/index.aspx?lang=en-us

Discord: Romulator#0001
[Image: 3f6f01a904.png]
02-12-2016, 12:48 AM
Find
Guest
Unregistered

 
#3
Solved: 2 Years, 6 Months, 3 Weeks ago RE: Crash after starting and picking up a few items
(02-12-2016, 12:48 AM)Romulator Wrote: Your version of OpenGL is 3.2.0, where SOMA's minimum is 3.3.0.
Don't know where you got that idea, but glxinfo tells me:
OpenGL version string: 4.5.0 NVIDIA 352.79
You might be confusing the GLES version, 3.1.

(02-12-2016, 12:48 AM)Romulator Wrote: Have you checked for any updates for your graphics card? Since you're using an nVidia, you should be able to check here: http://www.nvidia.com/Download/index.aspx?lang=en-us
I'm using Debian's Nvidia packages, for which 352.79-1 is the latest available. 355.11 is about to become available (well, unstable) soon though, which I will try.
02-13-2016, 07:48 PM
Romulator Offline
Not Tech Support ;-)

Posts: 3,577
Threads: 61
Joined: Jan 2013
Reputation: 193
#4
Solved: 2 Years, 6 Months, 3 Weeks ago RE: Crash after starting and picking up a few items
(02-13-2016, 07:48 PM)Guest Wrote:
(02-12-2016, 12:48 AM)Romulator Wrote: Your version of OpenGL is 3.2.0, where SOMA's minimum is 3.3.0.
Don't know where you got that idea, but glxinfo tells me:
OpenGL version string: 4.5.0 NVIDIA 352.79
You might be confusing the GLES version, 3.1.

Strange - because your hpl.log actually claims you're running 3.2.0 in terms of OpenGL compatibility. Since that's what it says in the log, I had to go off that.

Quote:Initializing Graphics Module
--------------------------------------------------------
Init lowlevel graphics: 1920x1080 bpp:32 rr: 60 fs:0 ms:0 driver: 0 cap:'SOMA Loading...' posSad-1x-1)
Creating window: (-1,-1) 1920 x 1080 - 32 bpp flags: 4099
Setting display mode: 1920 x 1080 - 32 bpp 60 hz
Init Glew...OK
Setting up OpenGL
Vendor: NVIDIA Corporation
Renderer: GeForce GTX 660M/PCIe/SSE2
Version: 3.2.0

I'm not too sure where to go from here, since that's a likely culprit, but I'll forward this over to one of our other more knowledgeable tech gurus and he may be able to help Smile

Discord: Romulator#0001
[Image: 3f6f01a904.png]
02-13-2016, 11:28 PM
Find
Mudbill Offline
Muderator

Posts: 3,682
Threads: 58
Joined: Apr 2013
Reputation: 171
#5
Solved: 2 Years, 6 Months, 3 Weeks ago RE: Crash after starting and picking up a few items
I don't think that "Version" is the OpenGL version. I think it might be the Nvidia driver version. I believe with Amnesia, the OpenGL was this line:
GLSL Version: 1.50 NVIDIA via Cg compiler
The issue with the version (as compared to the other "Version" string) still applies though.

02-14-2016, 02:18 AM
Find
plutomaniac Offline
Super Moderator

Posts: 6,369
Threads: 45
Joined: May 2011
Reputation: 183
#6
Solved: 2 Years, 6 Months, 3 Weeks ago RE: Crash after starting and picking up a few items
The Version is what's reported after the renderer, what Romulator said, and not GLSL which is a different thing. A kepler based Nvidia 660M card obviously doesn't support only OpenGL 3.2.0 but rather 4.5 or more like that other utility you used reported. However, whether it's game or driver-related, the game detects OpenGL 3.2.0 which is below requirements and it may be the reason for the crashes.

I don't have Linux knowledge but what I can suggest is to use the latest beta from Steam and maybe older/different Nvidia drivers. The only thing that I could find about such an issue is this steam forum thread.
02-16-2016, 11:23 PM
Find
Jump to the post that solved this thread.




Users browsing this thread: 1 Guest(s)