Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Surround Sound [solved]
zak Offline
Junior Member

Posts: 44
Threads: 4
Joined: Aug 2009
Reputation: 0
#1
Solved: 4 Years, 3 Months, 1 Week ago Surround Sound [solved]

Hi,
I noticed nothing coming out of my rear speakers and having only stereo sound. I hope 5.1 surround sound works on linux, too?

Quote:0. PulseAudio Software(OpenAL default)
1. ALSA Software on default
2. ALSA Software on SB Audigy 2 ZS [SB0350] [ADC Capture/Standard PCM Playback] (hw:0,0)
3. ALSA Software on SB Audigy 2 ZS [SB0350] [Multichannel Capture/PT Playback] (hw:0,2)
4. ALSA Software on SB Audigy 2 ZS [SB0350] [Multichannel Playback] (hw:0,3)
5. ALSA Software on SB Audigy 2 ZS [SB0350] [p16v] (hw:0,4)
6. OSS Software
7. PortAudio Software

I tried every option without success. 0 is not working for me because of missing PulseAudio software, do I have to use this? I think it should work with 1, too.

Anyway, not so important right now. I wish you good luck on releasing the game tomorrow!

Zak
09-07-2010, 08:26 PM
Find
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
#2
Solved: 4 Years, 3 Months, 1 Week ago RE: Surround Sound

This sounds like an openal driver issue. Do other games output in the rear speakers? Try making sure you have the latest version of openal-soft's openal library intalled and rerun the checklibs script in the game install directory. The version included with the game is the latest as of a few weeks ago, but most often than not the checklibs script will find a system version of the lib to use.

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
09-07-2010, 08:35 PM
Website Find
zak Offline
Junior Member

Posts: 44
Threads: 4
Joined: Aug 2009
Reputation: 0
#3
Solved: 4 Years, 3 Months, 1 Week ago RE: Surround Sound

Quote:$ ldd Amnesia.bin64 | grep open
libopenal.so.1 => /usr/lib/libopenal.so.1 (0x00007fcd902c2000)

$ file /usr/lib/libopenal.so.1
/usr/lib/libopenal.so.1: symbolic link to `libopenal.so.1.12.854'
It comes with debian (unstable) package libopenal1.

Unfortunately I don't know/have any other surround-sound games. But if I type
Quote:aplay -Dsurround51 Surround-SDL-testfiles/chan-id.wav
...I hear everything correctly from the right position. But in this case no OpenAL is used, correct?
Anything else I can try?

I called the checklibs script before of course.
09-07-2010, 08:48 PM
Find
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
#4
Solved: 4 Years, 3 Months, 1 Week ago RE: Surround Sound

In the game directory, try

ln -sf all/libopenal.so.1 libs64

Then rerun the game. ( that will make amnesia use the included version of openal instead. You can check by doing ldd again )

If that still doesn't work I'd suggest checking the openalsoft mailing list.

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
09-07-2010, 08:55 PM
Website Find
zak Offline
Junior Member

Posts: 44
Threads: 4
Joined: Aug 2009
Reputation: 0
#5
Solved: 4 Years, 3 Months, 1 Week ago RE: Surround Sound

Doesn't change anything :-(

I will look further into this and maybe check the openal mailing list as you mentioned and post the result here then.

Thanks for the quick answers.
09-07-2010, 09:01 PM
Find
nofsky Offline
Senior Member

Posts: 423
Threads: 13
Joined: Sep 2008
Reputation: 1
#6
Solved: 4 Years, 3 Months, 1 Week ago RE: Surround Sound

I read on the steam forums that you have to edit the settings.cfg file to enable hardware sound for 5.1. That was on Windows but maybe this is the case here too?

Here's the thread
http://forums.steampowered.com/forums/sh...?t=1423706
09-07-2010, 09:08 PM
Find
zak Offline
Junior Member

Posts: 44
Threads: 4
Joined: Aug 2009
Reputation: 0
#7
Solved: 4 Years, 3 Months, 1 Week ago RE: Surround Sound

Thanks nofsky but I already found out just now and it works :-)

For the record (at least Debian unstable):

In OpenAL configuration file /etc/openal/alsoft.conf or user-specific file ~/.alsoftrc
Quote:format = AL_FORMAT_51CHN32
(32-bit float 5.1 output)

For ALSA in section [alsa]:
Quote:device = surround51

And maybe further settings at will. There are a lot of options, e.g. for speaker positioning and so on.

Some more information maybe here: http://www.halfgaar.net/surround-sound-in-linux
09-07-2010, 09:23 PM
Find




Users browsing this thread: 1 Guest(s)