Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Installation problem (Lua error detected: cannot open shared/utils.lua)
prischeyadro Offline
Junior Member

Posts: 2
Threads: 1
Joined: Sep 2010
Reputation: 0
#1
Solved: 3 Years, 9 Months ago [SOLVED] Installation problem (Lua error detected: cannot open shared/utils.lua)

Thanks for releasing Linux-version of Amnesia.
I use ArchLinux, i686 with KDE4 and unfortunately can't complete the installation.

Trying to install the game with console command
./amnesia_tdd_1.0.sh -u -d ~/amnesia/ -k ST******** -l --nox11
(interactive install fails as well and also crashes plasma if compositing is enabled. Anyway, it's not very interesting because of non-interactive install option available)
It gives the following:
Verifying archive integrity... All good.
Uncompressing Installer for Amnesia - The Dark Descent.............
Uncompressing sub archive.................................................
.............................................................................
...........
Collecting info for this system...
Operating system: linux
CPU Arch: x86
ldd: exited with unknown exit code (135)
./startupinstaller.sh: line 134:  4146 Segmentation fault      `pwd`/$FRBIN $ARGS
Nixstaller version 0.5.1, Copyright (C) 2006 - 2009 of Rick Helmus
Nixstaller comes with ABSOLUTELY NO WARRANTY.
Nixstaller is free software, and you are welcome to redistribute it
under certain conditions; see the about section for details.
Error: Lua error detected: cannot open shared/utils.lua: No such file or directory
Google says nothing. What could it be?
09-08-2010, 09:05 PM
Find
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
#2
Solved: 3 Years, 9 Months ago RE: Installation problem (Lua error detected: cannot open shared/utils.lua)

Try
./amnesia_tdd_1.0.sh --target TEMP --keep --noexec
then see if it extracted correctly. Then you can manually run the startupinstaller.sh from there OR if it extracted the binaries just run ./bin/linux/x86/gtk (or fltk, or ncurs)

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
09-08-2010, 10:14 PM
Website Find
prischeyadro Offline
Junior Member

Posts: 2
Threads: 1
Joined: Sep 2010
Reputation: 0
#3
Solved: 3 Years, 9 Months ago RE: Installation problem (Lua error detected: cannot open shared/utils.lua)

Thanks, installed flawlessly with startupinstaller.sh
09-08-2010, 10:53 PM
Find




Users browsing this thread: 1 Guest(s)