Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Garbled sound
Bobbin
Unregistered

 
#1
Not Solved Garbled sound
The game sometimes switches to a "garbled sound" mode. Symptoms are:
  1. Strong static, like when using a failing speaker
  2. Voices barely audible (but audible)
  3. Sounds and subtitles play faster (but not instantly)
  4. Pulseaudio (pavucontrol) doesn't show SOMA's output stream anymore (but it's still audible).
This happens frequently during lag spikes (I'm currently RMA'ing my main memory, and I only have the minimum 4 GB of RAM, which causes the game to swap a lot in some situations), but sometimes just at random. In rare cases it switches back and forth between normal and garbled every few seconds, but usually the only way to restore sound is a restart.

Only sound of SOMA is affected, I can play a tune in parallel and it sounds just fine. Graphics are fine, too, no lag or glitches here, I think (as there are intentional glitches, they would be a bit easier to overlook than usual).

This is very annoying, especially since it makes the subtitles a bit too fast to read, and can only be recovered by full restart, which takes quite a bit of time.

Software:
SOMA x86_64 Steam Build 1048044
OpenGL core profile version string: 4.4.0 NVIDIA 361.28
OpenGL version string: 4.5.0 NVIDIA 361.28
PulseAudio 8.0
Linux cami 4.1.15-gentoo-r1 x86_64

Hardware:
OpenGL renderer string: GeForce GTX 650/PCIe/SSE2 [2GB GDDR5]
Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
Intel® Core™ i7 CPU 920 @ 2.67GHz GenuineIntel GNU/Linux [4GB DDR3]
07-28-2016, 01:32 PM
Reply
Bobbin Offline
Junior Member

Posts: 1
Threads: 0
Joined: Jul 2016
Reputation: 0
#2
Not Solved RE: Garbled sound
Why is this thread marked solved without any replies and without being closed? I still need a solution.
07-29-2016, 11:29 AM
Find Reply
zaggynl
Unregistered

 
#3
Not Solved RE: Garbled sound
Workaround I apply for games that have these issues for me (tombraider, mad max):
from:
https://wiki.archlinux.org/index.php/Pul..._crackling

Edit this file:
sudo nano /etc/pulse/default.pa
Change:
load-module module-udev-detect
to:
load-module module-udev-detect tsched=0

Restart the PulseAudio server:
$ pulseaudio -k
$ pulseaudio --start

Note: this doesn't instantly fix the issue in SOMA, after starting the game, let it sit for a couple minutes, corrects by itself.
10-31-2016, 07:57 PM
Reply
Jump to the post that solved this thread.


[-]
Quick Reply
Message
Type your reply to this message here.

Human Verification
Please tick the checkbox that you see below. This process is used to prevent automated spam bots.



Users browsing this thread: 1 Guest(s)