Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
crash at startup - SteamOS
loadrunner
Unregistered

 
#1
Not Solved crash at startup - SteamOS
Hi,

I'm using SteamOS 2.0 on an Intel G4400 CPU + Nvidia GTX 750 Ti (driver 367.27)
and the game crashes (segfault) right after the fist screen. (it's a loading screen I guess, it takes a few seconds)
I never managed to get past it.


hpl.log Wrote:Loading data from cloud storage
--------------------------------------------------------
Files on steam cloud:
No could files found!
Time: 0
--------------------------------------------------------

Version 1.10
-------- THE HPL ENGINE LOG ------------
Creating Engine Modules
--------------------------------------------------------
Creating job manager with 0 threads and 1024 jobs
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating generate module
Creating haptic module
Creating scene module
Creating script module
Creating lipsync module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating loader handlers
Creating resource managers
Adding loaders to handlers
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Init lowlevel graphics: -1x-1 bpp:32 rr: 60 fs:0 ms:0 driver: 0 cap:'SOMA Loading...' posSad-1x-1)
Available drivers:
(0) - 'x11'
(1) - 'dummy'
Creating window: (-1,-1) 1920 x 1080 - 32 bpp flags: 4099
Setting display mode: 1920 x 1080 - 32 bpp 60 hz
Init Glew...OK
Setting up OpenGL
Vendor: NVIDIA Corporation
Renderer: GeForce GTX 750 Ti/PCIe/SSE2
Version: 3.2.0 NVIDIA 367.27
Max texture image units: 32
Max texture coord units: 192
Max texture buffer size: 134217728
Max texture array slices: 2048
Max user clip planes: 8
Two sided stencil: 1
Vertex Buffer Object: 1
Anisotropic filtering: 1
Max Anisotropic degree: 16
Multisampling: 1
Texture compression: 1
Texture compression S3TC: 1
Texture compression 3DC: 1
Texture sRGB: 1
Geometry Instancing: 1
Auto generate MipMaps: 1
Render to texture: 1
Max draw buffers: 8
Max color render targets: 8
Packed depth-stencil: 1
Texture float: 1
GLSL Version: 1.50 NVIDIA via Cg compiler
ShaderModel 2: 1
ShaderModel 3: 1
ShaderModel 4: 1
Max vertex uniforms: 2048
Max fragment uniforms: 4096
OGL ATIFragmentShader: 0
Tesselation: 0
MultiBindTex: 1
Initializing DevIL
Vendor String: Abysmal Software
Version String: Developer's Image Library (DevIL) 1.7.8
Version Number: 178
WARNING: Sampler aSpecularMap doesn't exist or is unused, could not bind it to unit 2
WARNING: Sampler aSpecularMap doesn't exist or is unused, could not bind it to unit 2
WARNING: Sampler aSpecularMap doesn't exist or is unused, could not bind it to unit 2
WARNING: Sampler aSpecularMap doesn't exist or is unused, could not bind it to unit 2
WARNING: Sampler aSpecularMap doesn't exist or is unused, could not bind it to unit 2
WARNING: Sampler aSpecularMap doesn't exist or is unused, could not bind it to unit 2
WARNING: Sampler aSpecularMap doesn't exist or is unused, could not bind it to unit 2
WARNING: Sampler aAlphaMap doesn't exist or is unused, could not bind it to unit 1
Adding engine materials
Adding engine post effects
WARNING: Sampler colorMap doesn't exist or is unused, could not bind it to unit 2
WARNING: Sampler offsetMap doesn't exist or is unused, could not bind it to unit 3
--------------------------------------------------------

Initializing Sound Module
--------------------------------------------------------
Initializing FMOD.
Available sound Drivers:
= PULSEAUDIO =
0 - "Default Output Device"
1 - "Built-in Audio Digital Surround 5.1 (HDMI)"
= ALSA =
0 - "default"
1 - "null"
2 - "pulse"
3 - "cards"
4 - "sysdefault"
5 - "front"
6 - "rear"
7 - "center_lfe"
8 - "side"
9 - "surround21"
10 - "surround40"
11 - "surround41"
12 - "surround50"
13 - "surround51"
14 - "surround71"
15 - "iec958"
16 - "spdif"
17 - "hdmi"
18 - "dmix"
19 - "dsnoop"
20 - "modem"
21 - "phoneline"
22 - "hw"
23 - "plughw"
24 - "plug"
25 - "shm"
26 - "tee"
27 - "file"
Picking Output[0] Driver[0] and SpeakerMode[2]
--------------------------------------------------------

Initializing Game Module
--------------------------------------------------------
Adding engine updates
--------------------------------------------------------

User Initialization
--------------------------------------------------------
--------------------------------------------------------

Game Running
--------------------------------------------------------
Loading keybinds - file version:0
New default keybindings detected - trashing old keybindings.
Loading keybinds - file version:5

dmesg Wrote:[ 594.543220] Soma.bin.x86_64[1539]: segfault at 0 ip 0000000000d978b8 sp 00007ffd03b1f860 error 4 in Soma.bin.x86_64[400000+18e3000]
08-11-2016, 09:28 PM
Reply
Romulator Offline
Not Tech Support ;-)

Posts: 3,586
Threads: 62
Joined: Jan 2013
Reputation: 195
#2
Not Solved RE: crash at startup - SteamOS
It appears your nVidia card is unable to run the game fully, as it is rendering OpenGL v3.2.0, whereas SOMA requires 3.3.0 or above. You can try checking for any updates to your Graphics Card drivers here.

If there aren't any updates, there isn't much you can do. Sorry about that! :/

Discord: Romulator#0001
[Image: 3f6f01a904.png]
(This post was last modified: 08-12-2016, 04:30 AM by Romulator.)
08-12-2016, 04:29 AM
Find Reply
loadrunner
Unregistered

 
#3
Not Solved RE: crash at startup - SteamOS
I don't know what the problem is, but it's not that.
I saw that (that it detects 3.2) and I also saw other topics here in which people claim SOMA detects 3.2 even if their system supports 3.3+. (people also with nvidia GPUs, I think .. ?)
The 367.27 nvidia driver, which is preinstalled with SteamOS 2 (stable) is pretty new (2016.6.13) and it supports OpenGL 4.5. (also glxinfo reports OpenGL 4.5)
I don't want to manually install a different/newer version because SteamOS doesn't recommend that and it might break future updates.

But regardless of that, shouldn't SOMA run on a stock SteamOS?
On Steam it claims it does work with SteamOS and it should.
I bought it because of that.

I will do some more digging and let you know if I find anything, but please don't dismiss this so quickly.
08-12-2016, 09:57 AM
Reply
Romulator Offline
Not Tech Support ;-)

Posts: 3,586
Threads: 62
Joined: Jan 2013
Reputation: 195
#4
Not Solved RE: crash at startup - SteamOS
Pardon me if it sounds like I'm dismissing - that wasn't my intention!

I'm, unfortunately, just going off the Graphics Card Troubleshooting Guide, which states under point 2:

Troubleshooting Guide Wrote:If Version says 3.3.0 or more, your graphics card is supported.

As someone who doesn't use SteamOS, I can't confirm nor deny compatibility, and my AMD card uses version 4.1, so I personally can't do any troubleshooting. If you can find anything though, it would really help! In the meantime, I'll assign this thread to one of the devs and see if they can or will assist further.

Sorry I cannot be of more help!

Discord: Romulator#0001
[Image: 3f6f01a904.png]
08-12-2016, 11:23 AM
Find Reply
loadrunner
Unregistered

 
#5
Not Solved RE: crash at startup - SteamOS
I just tried the drm free version (from humble bundle) on a different Ubuntu installation with the same Nvidia 750 Ti, last available drivers (367.35 - 2016.7.15) and I have the exact same problem. (if crashes right after the loading bar from the first screen reaches 100%)

The game reports the same version 3.2, but glxinfo says 4.5:
Quote:OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 750 Ti/PCIe/SSE2
OpenGL core profile version string: 4.5.0 NVIDIA 367.35
OpenGL core profile shading language version string: 4.50 NVIDIA


It works on different machine with Intel integrated GPU, which ironically is not supported. (but I get around 10 FPS so it's unplayable)

I'm available for tests or debugging.
08-12-2016, 11:35 AM
Reply
loadrunner
Unregistered

 
#6
Not Solved RE: crash at startup - SteamOS
I figured it out eventually, after a lot of tests.
It's not related to the GPU, drivers or SteamOS, it's related to the CPU.

I run most of my apps/games inside VMs. I use PCI and USB passthrough, so everything works pretty much exactly like on a barebone machine - no issue there.
Anyway, the only detail relevant here is that I only assigned 1 virtual core to SteamOS, which apparently causes Soma to segfault .. if I assign 2 or more, it works fine.
Even if a single core CPU is below the minimum required specs, that's still pretty bad.
I hope it's a bug which can be easily fixed, because the actual CPU useage is quite good. It would definitely work fine, at least in my scenario.
And even if it didn't, it shouldn't crash.
I run all my games on SteamOS with 1 virtual core and most of them work fine. (and the rest just have performance issues, but they still work)

I really hope we get a patch for this.

Thanks.
08-12-2016, 03:23 PM
Reply
Mudbill Offline
Muderator

Posts: 3,734
Threads: 59
Joined: Apr 2013
Reputation: 173
#7
Not Solved RE: crash at startup - SteamOS
Thank you for reporting back! I'm sure this will be useful for the devs and others who have similar issues Smile

08-13-2016, 03:32 PM
Find Reply
ace102 Offline
Junior Member

Posts: 3
Threads: 0
Joined: Nov 2018
Reputation: 0
#8
Not Solved RE: crash at startup - SteamOS
Might want to look at this post.
https://www.frictionalgames.com/forum/thread-54507.html

Cheers!
11-30-2018, 07:51 PM
Find Reply
Jump to the post that solved this thread.


[-]
Quick Reply
Message
Type your reply to this message here.

Human Verification
Please tick the checkbox that you see below. This process is used to prevent automated spam bots.



Users browsing this thread: 1 Guest(s)