Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Skybox problem on Mac
PythonBlue Offline
Member

Posts: 124
Threads: 13
Joined: Feb 2012
Reputation: 8
#1
Skybox problem on Mac

So I've decided to re-explore Amnesia modding, only to find that skyboxes aren't working: it only displays one face of a cubemap across all six sides. I've read a few threads here that suggest that the problem is a broken LibIL dll file for Windows users.

Problem is that I'm a Mac user, so I'd need the dylib version instead to confirm. Does anyone have this file, preferably for version 1.3.0 of the game? If no one does, then is there any hope for the game getting updated again?

Thanks in advance. I also confirmed that the problem exists in A Machine for Pigs through modding that as well.

08-16-2016, 03:41 PM
Find Reply
Romulator Offline
Not Tech Support ;-)

Posts: 3,626
Threads: 62
Joined: Jan 2013
Reputation: 195
#2
RE: Skybox problem on Mac

Is it possible to install or extract the files from the 1.2.0 update? I believe the change in the DevIL.dll file occurred between 1.3 and 1.3.1, but there were no changes to DevIL.dll beforehand.

If that's the case, you should be able to just use Frictional's official updating page for that: https://www.frictionalgames.com/forum/thread-24334.html

Otherwise, yep, gotta wait for another Mac user to help you out!

Discord: Romulator#0001
[Image: 3f6f01a904.png]
08-16-2016, 06:54 PM
Find Reply
PythonBlue Offline
Member

Posts: 124
Threads: 13
Joined: Feb 2012
Reputation: 8
#3
RE: Skybox problem on Mac

Thanks for responding, first of all, Romulator.

The stranger part is that I already tried that via finding a download of the un-updated demo of the game, and the error report says this bit, among other things:

"Dyld Error Message:
Library not loaded: @rpath/libIL.1.dylib
Referenced from: /Volumes/VOLUME/*/Amnesia.app/Contents/MacOS/AmnesiaSteam
Reason: Incompatible library version: AmnesiaSteam requires version 3.0.0 or later, but libIL.1.dylib provides version 1.0.0"

And that's another thing I noticed, which might be part of the problem: version 1.2 and earlier titled the file as "libDevIL" a la Windows systems, but in 1.3 and in Machine for Pigs, it was renamed (hopefully?) to "libIL.1". SOMA has the same filename in its Mac version, but I even tried that, only to get an error about the wrong architecture.

08-16-2016, 07:13 PM
Find Reply




Users browsing this thread: 1 Guest(s)