Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] Strange error when using specific #include
Jesscar Offline
Junior Member

Posts: 2
Threads: 1
Joined: Jan 2017
Reputation: 0
#1
[Solved] Strange error when using specific #include

Hi everyone.

I'm working on my first SOMA custom story and I'm trying to add a working terminal with GUI to the map.

However, when I add this one line of code:

#include "helper_imgui_station.hps"

I get this error:

[Image: yrbaonh.png]

The error only occurs when that line is there. When I remove it, the map loads just fine. There is no other terminal related code in my script. I've tried verifying the game cache but it didn't fix the issue.

Here is my entire script file:
http://pastebin.com/Qg7mC7Xv

Solution:

I fixed it! It was an easy fix. Just add the line:

#include "helper_imgui_station_apps_common.hps"


So the includes look like this:

#include "helper_imgui_station.hps"
#include "helper_imgui_station_apps_common.hps"
(This post was last modified: 01-05-2017, 03:40 AM by Jesscar.)
01-05-2017, 03:18 AM
Find Reply
Romulator Offline
Not Tech Support ;-)

Posts: 3,586
Threads: 62
Joined: Jan 2013
Reputation: 195
#2
RE: [Solved] Strange error when using specific #include

Ah yes - because of how #include "helper_imgui_station.hps" works, it needs to include functions from the other two imgui helpers.

Glad to hear you got it solved in the end Smile

Discord: Romulator#0001
[Image: 3f6f01a904.png]
01-05-2017, 05:07 AM
Find Reply


[-]
Quick Reply
Message
Type your reply to this message here.

Human Verification
Please tick the checkbox that you see below. This process is used to prevent automated spam bots.



Users browsing this thread: 1 Guest(s)