Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support | Gametee


Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Crosshair/interact icons gone completely!
Author Message
Venom Fox Offline
Junior Member

Posts: 30
Joined: Mar 2016
Reputation: 0
Post: #1
Crosshair/interact icons gone completely!

So apparently the crosshair and all the interact icons are invisible in my mods now.
This just suddenly happened. I got a message on Perditio's steam workshop page from a player who said that he has no crosshair, and then I noticed that the mod that I'm working on atm doesn't have any crosshair/interact icons either!

Then I tried out Archipelago and nope, no crosshair or the icons working in there either.
They used to work. Is there some kind of SOMA patch that's causing this?

Also, I've been using the message module in my mods but it doesn't seem like that's working anymore either.
04-15-2017 10:12 AM
Find all posts by this user Quote this message in a reply
Romulator Offline
Hyper Rare Lurantis

Posts: 3,365
Joined: Jan 2013
Reputation: 188
Post: #2
RE: Crosshair/interact icons gone completely!

As far as my game files are concerned, the crosshair and interact icons are still in my original game files. They are located at SOMA\graphics\hud. If your mod doesn't use any custom icons, the game will fallback their load on these ones; so that shouldn't be an issue if they are "missing" from your mod.

Is it possible a setting in the options has just been turned off? I'm pretty sure there is one about Crosshair icons.

However, the fact the message module isn't working, they may be connected. SOMA had a small update a few days ago. Assuming that is the one Abion47 made, then I'll send him a message to have a look over it; something may have become incompatible in the codes.

You can check your mod's hpl.log file to confirm exactly what is wrong. In a Windows system, the mod log files are located at Documents\My Games\Soma\Mods.

Discord: Aceromulator#4942
(This post was last modified: 04-15-2017 10:27 AM by Romulator.)
04-15-2017 10:26 AM
Find all posts by this user Quote this message in a reply
Venom Fox Offline
Junior Member

Posts: 30
Joined: Mar 2016
Reputation: 0
Post: #3
RE: Crosshair/interact icons gone completely!

(04-15-2017 10:26 AM)Romulator Wrote:  As far as my game files are concerned, the crosshair and interact icons are still in my original game files. They are located at SOMA\graphics\hud. If your mod doesn't use any custom icons, the game will fallback their load on these ones; so that shouldn't be an issue if they are "missing" from your mod.

Is it possible a setting in the options has just been turned off? I'm pretty sure there is one about Crosshair icons.

However, the fact the message module isn't working, they may be connected. SOMA had a small update a few days ago. Assuming that is the one Abion47 made, then I'll send him a message to have a look over it; something may have become incompatible in the codes.

You can check your mod's hpl.log file to confirm exactly what is wrong. In a Windows system, the mod log files are located at Documents\My Games\Soma\Mods.

Apparently the message module is working after all (When opening the mod via the modlauncher)
I'm pretty sure the option isn't turned off, and none of my mods use any custom interact icons. Confused
04-15-2017 10:30 AM
Find all posts by this user Quote this message in a reply
Venom Fox Offline
Junior Member

Posts: 30
Joined: Mar 2016
Reputation: 0
Post: #4
RE: Crosshair/interact icons gone completely!

(04-15-2017 10:26 AM)Romulator Wrote:  As far as my game files are concerned, the crosshair and interact icons are still in my original game files. They are located at SOMA\graphics\hud. If your mod doesn't use any custom icons, the game will fallback their load on these ones; so that shouldn't be an issue if they are "missing" from your mod.

Is it possible a setting in the options has just been turned off? I'm pretty sure there is one about Crosshair icons.

However, the fact the message module isn't working, they may be connected. SOMA had a small update a few days ago. Assuming that is the one Abion47 made, then I'll send him a message to have a look over it; something may have become incompatible in the codes.

You can check your mod's hpl.log file to confirm exactly what is wrong. In a Windows system, the mod log files are located at Documents\My Games\Soma\Mods.

I think the SOMA updates have something to do with this because these errors just appeared out of nowhere
04-15-2017 02:39 PM
Find all posts by this user Quote this message in a reply
Post Reply 


[-]
Quick Reply
Message
Type your reply to this message here.

Please answer:



User(s) browsing this thread: 1 Guest(s)