Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Custom story won't show up in the game
Servantgrunt01
Unregistered

 
#1
Not Solved Custom story won't show up in the game
I have installed the level editor and started creating a custom story. I saved it in the map folder as the same name as my custom story. But when i launch the game it won't show up. What is the problem?
03-19-2018, 06:53 AM
Reply
Romulator Offline
Not Tech Support ;-)

Posts: 3,623
Threads: 62
Joined: Jan 2013
Reputation: 195
#2
Not Solved RE: Custom story won't show up in the game
A custom story needs to be set up like a custom story in order for it to appear in your game's Custom Story list. The minimum required to make the CS appear is a custom_story_settings.cfg file, and a single map. The config file must be kept inside of a folder within your custom_stories directory in Amnesia's directory.

See Step 3 here for more information: https://wiki.frictionalgames.com/hpl2/am...stom_story

You should also, simply because it helps with the Custom Story creation process, set up the Developer Environment if you have not done so already: https://wiki.frictionalgames.com/hpl2/am...evenvguide

Discord: Romulator#0001
[Image: 3f6f01a904.png]
03-19-2018, 06:25 PM
Find Reply
Servantgrunt01
Unregistered

 
#3
Not Solved RE: Custom story won't show up in the game
I did it but it still won't work
03-20-2018, 09:14 PM
Reply
Mudbill Offline
Muderator

Posts: 3,816
Threads: 59
Joined: Apr 2013
Reputation: 177
#4
Not Solved RE: Custom story won't show up in the game
Could you package your custom story and upload it? Then we can take a look and see where the issue is.

03-21-2018, 02:33 PM
Find Reply
Servantgrunt01
Unregistered

 
#5
Not Solved RE: Custom story won't show up in the game
How do i do that?
03-21-2018, 03:15 PM
Reply
Mudbill Offline
Muderator

Posts: 3,816
Threads: 59
Joined: Apr 2013
Reputation: 177
#6
Not Solved RE: Custom story won't show up in the game
Use an archiving tool like WinRAR or 7Zip to create a .zip or .rar file of the entire folder, then upload it to something like http://mixtape.moe and give the link in a comment.

03-21-2018, 03:59 PM
Find Reply
Servantgrunt01
Unregistered

 
#7
Not Solved RE: Custom story won't show up in the game
How do i do that? Sorry but i am bad at this
04-07-2018, 04:22 PM
Reply
Mudbill Offline
Muderator

Posts: 3,816
Threads: 59
Joined: Apr 2013
Reputation: 177
#8
Not Solved RE: Custom story won't show up in the game
Ok, try this then.
  1. Download WinRAR from this website: https://www.rarlab.com/download.htm
  2. After you've installed it, right click your custom story folder and choose "Add to archive..." and click OK.
  3. This will give you a new file that ends with .rar (but you probably have file extensions hidden).
  4. Go to http://mixtape.moe and upload your file (as long as it's under 100 MB).
  5. Once the upload is complete, you will get a link that you must copy and paste into a comment here so that we can download it.

(This post was last modified: 04-07-2018, 04:35 PM by Mudbill.)
04-07-2018, 04:35 PM
Find Reply
Servantgrunt01
Unregistered

 
#9
Not Solved RE: Custom story won't show up in the game
https://my.mixtape.moe/evzqsc.rar
04-08-2018, 08:05 AM
Reply
Mudbill Offline
Muderator

Posts: 3,816
Threads: 59
Joined: Apr 2013
Reputation: 177
#10
Not Solved RE: Custom story won't show up in the game
Upon opening the folder, I immediately see an issue. Your extensions are wrong.

[Image: E4KQzin.png]

See how these end in .txt? Most likely this happens because you have extensions hidden on your machine, therefore when you add an extension, there's an additional extension appended but hidden.

Enable extensions. It should be in Explorer > View > File extensions (for Windows 10).

Upon further inspection, I see another error in your custom_story_settings file: It's missing the closing tag.
[Image: vcgtq77.png]
It should end with /> at the end.

Your extra_english file seems fine, except the extension, and that it should end in .lang not _lang.

04-08-2018, 04:50 PM
Find Reply
Jump to the post that solved this thread.


[-]
Quick Reply
Message
Type your reply to this message here.

Human Verification
Please tick the checkbox that you see below. This process is used to prevent automated spam bots.



Users browsing this thread: 1 Guest(s)