Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
extra-english.lang not working properly (Yes, I did check the stickied thread).
Oliwarrior123 Offline
Junior Member

Posts: 31
Threads: 9
Joined: Jul 2012
Reputation: 0
#1
Information  extra-english.lang not working properly (Yes, I did check the stickied thread).

Hello everyone!

I've just returned to Amensia custom story development after a 3 year break. It's awesome to be back and brings back lots of memories of reading up on shit  I never understood anyways. Now I am a little more avid in programming, everything is much smoother for me. Except the dang lang file.

So I made a simple map with two keys. It's the introductory map, where you have a personal key and end up getting a master key (you will own it throughout the campaign). Problem is, when I set the CustomSubItemTypeName and enter that exact string in the .lang file, it doesn't do anything.

Here's what you need to know:
* Yes, I did save everything. I saved both the map and the .lang file. That's not the problem.
* I double checked the CustomSubItemTypeName thrice and cross-referenced it in the .lang. It's exactly the same
* Yes, my extra-english.lang is not .lang.txt, nor is it located in its own folder; current organisation is: /custom_stories/WIP/extra-english.lang
* CustomSubItemTypeName is "MasterKey".
* Here is the .lang file:

<LANGUAGE>
  <CATEGORY Name="WIP Story">
     <Entry Name="WIP">
        Oy Vey
     </Entry>
  </CATEGORY>
  <CATEGORY Name="Inventory">
        <Entry Name="ItemName_MasterKey">YourKeyName</Entry>
        <Entry Name="ItemDesc_MasterKey">YourKeyDescription</Entry>
    </CATEGORY>
</LANGUAGE>

Can any of you help identify my error here? I am unable to see why it doesn't show up in-game. The CS name and desc is showing up fine, just not the key.

Thanks for anyone willing to give it a go,
Oliver
05-27-2018, 01:45 PM
Find Reply
Mudbill Offline
Muderator

Posts: 3,674
Threads: 58
Joined: Apr 2013
Reputation: 171
#2
RE: extra-english.lang not working properly (Yes, I did check the stickied thread).

We resolved this on the Discord server. It was fixed by validating files in Steam.

05-27-2018, 04:09 PM
Find Reply




Users browsing this thread: 1 Guest(s)