Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Use Hardware Audio Option Resets itself
mattvintak Offline
Junior Member

Posts: 2
Threads: 1
Joined: Aug 2018
Reputation: 0
#1
Not Solved Use Hardware Audio Option Resets itself

Hi there. Pretty much what the title says: the Hardware Audio Option resets itself in Penumbra Overture. I'd like to use it, because I have a Corsaid Void 7.1 Surround Headphones, and the game it's surely amazing in 5.1 surround sound. But, every time I turn on the Use hardware audio option, it says to restart the game, and after I do so, the game resets the option. A while ago, when I bought the game, I had this problem, and resolved by googling, but I couldn't find the solution this time. I'm pretty sure it's just editing the config file, I just don't know how. Can anyone think of anything? I googled for hours lots of times, but can't find the solution anywhere.
08-27-2018, 04:26 AM
Find Reply
kirakatve Online
Frictional Games

Posts: 49
Threads: 8
Joined: Jan 2018
Reputation: 3
#2
Not Solved RE: Use Hardware Audio Option Resets itself

Hello!

The issue could be that your computer fails to save the config file because the game doesn't have the right permissions. Could you try running it as an administrator?

Otherwise you can go to the following path (or whatever you have set for Steam/GOG/HB):
C:\Program Files (x86)\Steam\steamapps\common\Penumbra Overture\redist\config
-> default_settings.cfg

You can probably adjust the following setting:
<Sound Volume="1.000000" UseSoundHardware="false" MaxSoundChannels="32" StreamUpdateFreq="10" UseThreading="true" MaxMonoChannelsHint="0" MaxStereoChannelsHint="0" />

Hope this helps!

Your friendly neighbour the community manager.
08-27-2018, 08:33 AM
Find Reply
mattvintak Offline
Junior Member

Posts: 2
Threads: 1
Joined: Aug 2018
Reputation: 0
#3
Not Solved RE: Use Hardware Audio Option Resets itself

I'm sorry for the late ansering, kirakatve.

Quote:The issue could be that your computer fails to save the config file because the game doesn't have the right permissions. Could you try running it as an administrator?

Done. It didn't work. The problem persists.

Quote:Otherwise you can go to the following path (or whatever you have set for Steam/GOG/HB):
C:\Program Files (x86)\Steam\steamapps\common\Penumbra Overture\redist\config
-> default_settings.cfg

You can probably adjust the following setting:
<Sound Volume="1.000000" UseSoundHardware="false" MaxSoundChannels="32" StreamUpdateFreq="10" UseThreading="true" MaxMonoChannelsHint="0" MaxStereoChannelsHint="0" />

What I did was modified both that file you suggested, the default_settings.cfg, and the settings.cfg in my documents, modifying the UseSoundHardware=true. I also, running the game as administrator, tried to configure the sound from inside the game, but it keeps resetting. What I did to run the game as an administrator was to run Penumbra.exe as administrator, but the problem persists. Anything else you could suggest?
09-06-2018, 07:30 AM
Find Reply


[-]
Quick Reply
Message
Type your reply to this message here.

Human Verification
Please tick the checkbox that you see below. This process is used to prevent automated spam bots.



Users browsing this thread: 1 Guest(s)