Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Textures keep changing while moving around
Uruii Offline
Junior Member

Posts: 7
Threads: 1
Joined: Nov 2010
Reputation: 0
#1
Solved: 2 Years, 3 Months, 3 Weeks ago Textures keep changing while moving around

When I try to play the game this happens:

http://www.youtube.com/watch?v=2SZWyn_5XoM

I have the latest patch.
I have Catalys AI disabled (I read somewhere that it would fix it, Also when it's enabled I get that)
I have the latest drivers.

System Specs:

Vista SP2
Intel® Core™2 Quad CPU Q9400 @ 2.66GHz(=10,64 GHz)
RAM: 4GB
64-Bit
ATI Radeon HD 4600
2x 596GB Hard Drive
1920x1080 - 60Hz HP monitor
(This post was last modified: 11-21-2010, 09:12 AM by Uruii.)
11-21-2010, 09:09 AM
Find
davva Offline
Member

Posts: 95
Threads: 1
Joined: Oct 2010
Reputation: 0
#2
Solved: 2 Years, 3 Months, 3 Weeks ago RE: Textures keep changing while moving around

try a different resulution

turn off Bloom effect and/or anti aliasing

(This post was last modified: 11-21-2010, 12:50 PM by davva.)
11-21-2010, 12:49 PM
Find
Uruii Offline
Junior Member

Posts: 7
Threads: 1
Joined: Nov 2010
Reputation: 0
#3
Solved: 2 Years, 3 Months, 3 Weeks ago RE: Textures keep changing while moving around

(11-21-2010, 12:49 PM)davva Wrote: try a different resulution

turn off Bloom effect and/or anti aliasing

Already tried that.
11-21-2010, 02:14 PM
Find
davva Offline
Member

Posts: 95
Threads: 1
Joined: Oct 2010
Reputation: 0
#4
Solved: 2 Years, 3 Months, 3 Weeks ago RE: Textures keep changing while moving around

then i'm pretty clueless, just wait for Thomas or Jens for a answer

11-21-2010, 02:22 PM
Find
tonewww Offline
Member

Posts: 244
Threads: 50
Joined: Mar 2009
Reputation: 1
#5
Solved: 2 Years, 3 Months, 3 Weeks ago RE: Textures keep changing while moving around

Try posting the HPL log i might be able to see whats going on

*Wishes Penumbra Tech Demo section would return*
11-21-2010, 02:58 PM
Find
Uruii Offline
Junior Member

Posts: 7
Threads: 1
Joined: Nov 2010
Reputation: 0
#6
Solved: 2 Years, 3 Months, 3 Weeks ago RE: Textures keep changing while moving around

(11-21-2010, 02:58 PM)tonewww Wrote: Try posting the HPL log i might be able to see whats going on

Where can I find the HPL log?

Edit# I found it:

-------- THE HPL ENGINE LOG ------------

Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating haptic module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating resource managers
Misc Creation
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Init low level graphics
Setting video mode: 800 x 600 - 32 bpp
Init Glee...OK
Setting up OpenGL
Max texture image units: 16
Max texture coord units: 16
Two sided stencil: 1
Vertex Buffer Object: 1
Anisotropic filtering: 1
Max Anisotropic degree: 16
Multisampling: 1
Vertex Program: 1
Fragment Program: 1
NV Register Combiners: 0
NV Register Combiners Stages: 11
ATI Fragment Shader: 1
Creating graphic systems
Creating Renderer2D
Renderer2D created
Creating Renderer3D
Load Renderer3D gpu programs:
Extrude
Diffuse Vertex
Diffuse Fragment
Fog
Creating fog textures: Solid Additive Alpha
init sky box
Renderer3D created
Creating screen buffers size 800.000000 : 600.000000
Creating programs
CG ERROR : The compile returned an error.
-----------------------------------
core/programs/PostEffect_Motion_fp.cg(32) : error C5013: profile does not support "for" statements and "for" could not be unrolled.
-----------------------------------
CG: Error loading: 'core/programs/PostEffect_Motion_fp.cg'!
ERROR: Couldn't create program 'PostEffect_Motion_fp.cg'
Dynamic loops in motion blur fp not supported, loading static instead.
RendererPostEffects created
Adding engine materials
--------------------------------------------------------

Initializing Sound Module
--------------------------------------------------------
Initializing OpenAL.
Trying to open software device... Success!
Device name: Generic Software
Number of mono sources: 32
--------------------------------------------------------

Initializing Game Module
--------------------------------------------------------
Adding engine updates
Initializing script functions
--------------------------------------------------------

User Initialization
--------------------------------------------------------
Initializing Penumbra: Black Plague
Version $Rev: 2595 $
Date $Date: 2008-05-03 15:09:49 +0200 (lö, 03 maj 2008) $
Checking Supported Profiles
Profile CG_PROFILE_ARBVP1 is supported
Profile CG_PROFILE_ARBFP1 is supported
Profile CG_PROFILE_GLSLV is supported
Profile CG_PROFILE_GLSLF is supported
Profile CG_PROFILE_GLSLC is supported
Trying to load vertex program!
Success!
Creating and binding ATI two unit diffuse shader to 1
All set up done, starting game!
--------------------------------------------------------

Game Running
--------------------------------------------------------
Loading collada for 'maps/level01_cells.dae' took: 360 ms
ERROR: Couldn't create material 'particle_rockpiece.mat'
ERROR: Couldn't create material 'particle_rockpiece.mat'
ERROR: Couldn't find particle system file 'particle_imp_generic_hard.ps'
ERROR: Couldn't create material 'particle_metalpiece.mat'
ERROR: Couldn't create material 'particle_metalpiece.mat'
ERROR: Couldn't create SoundEntity 'unbreak_impact_metal_soft_furniture_med.snt'
WARNING: Couldn't preload sound 'unbreak_impact_metal_soft_furniture_med'
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry joint parten '' is missing! Might be connected to bone.
ERROR: Couldn't find particle system file 'particle_imp_metal_special.ps'
ERROR: Couldn't find particle system file 'particle_imp_metal_special.ps'
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry joint parten '' is missing! Might be connected to bone.
WARNING: Parent 'group3' couldn't be found! Failed to attach 'artefact01_pointLight1' to 'artefact01'.Attaching directly to mesh.
ERROR: Couldn't find particle system file 'particle_imp_generic_hard.ps'
ERROR: SoundEnv 'soundenvs/EnvPreset012_Hallway.snv' does not exist!
ERROR: SoundEnv 'soundenvs/EnvPreset001j_Vent.snv' does not exist!
ERROR: SoundEnv 'soundenvs/EnvPreset104_DustyRoom.snv' does not exist!
ERROR: SoundEnv 'soundenvs/EnvPreset104_DustyRoom.snv' does not exist!
ERROR: SoundEnv 'soundenvs/EnvPreset104_DustyRoom.snv' does not exist!
ERROR: Couldn't find game entity 'descRBshelffloor'
WARNING: Couldn't find game entity 'descRBshelffloor'
Loading map 'level01_cells.dae' took: 5967 ms
--------------------------------------------------------

Statistics
--------------------------------------------------------
Medium framerate: 37.214363
--------------------------------------------------------

User Exit
--------------------------------------------------------
Saving to config
Saving keys
Saving to config
Saving keys
Reset maphandler
Exit Player
Exit Button Handler
Exit Map Handler
Exit Game Message Handler
Exit Radio Handler
Exit Inventory
Exit Fade Handler
Exit Save Handler
Exit Trigger Handler
Exit Attack Handler
Exit Notebook
Exit Numerical panel
Exit Intro story
Exit Death menu
Exit Graphics helper
Exit Main menu
Exit Player hands
Exit Music handler
Exit Map Load Text
Exit PreMenu
Exit Credits
Exit Ending
Exit Demo end text
Exit Gui Handler
Exit Sound Environment Handler
Exit Shooter
Saving config
Exit Effect Handler
Exit Game
--------------------------------------------------------

Exiting Gui Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Scene Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Input Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Sound Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Graphics Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Resources Module
--------------------------------------------------------
Done with tilesets
Done with fonts
Done with scripts
Done with particles
Done with sounds
Done with meshes
Done with materials
Done with Gpu programs
Done with images
Destroyed all textures
Done with sound entities
Done with animations
All resources deleted
--------------------------------------------------------

Exiting Physics Module
--------------------------------------------------------
--------------------------------------------------------

Exiting System Module
--------------------------------------------------------
--------------------------------------------------------

Deleting game setup provided by user
- Deleting lowlevel stuff.
Physics
Sound
Input
Resources
System
Graphics
Haptic
HPL Exit was successful!
Saving last config
Deleting ATI shader to 1
Deleting ATI shader to 0
Deleting ATI shader to 0
Deleting ATI shader to 0
(This post was last modified: 11-21-2010, 08:24 PM by Uruii.)
11-21-2010, 03:51 PM
Find
davva Offline
Member

Posts: 95
Threads: 1
Joined: Oct 2010
Reputation: 0
#7
Solved: 2 Years, 3 Months, 3 Weeks ago RE: Textures keep changing while moving around

i don't know shit about HPL logs but it looks like you're missing some files, try to reinstall the game (just make sure that you make a backup for your saved games rofl. if you do reinstall it that is^^)

11-22-2010, 04:46 PM
Find
xiphirx Offline
Senior Member

Posts: 662
Threads: 16
Joined: Nov 2010
Reputation: 5
#8
Solved: 2 Years, 3 Months, 3 Weeks ago RE: Textures keep changing while moving around

Try disabling motion blur. If I understand correctly from the log, your card doesn't support it...
11-22-2010, 07:32 PM
Find
Uruii Offline
Junior Member

Posts: 7
Threads: 1
Joined: Nov 2010
Reputation: 0
#9
Solved: 2 Years, 3 Months, 3 Weeks ago RE: Textures keep changing while moving around

(11-22-2010, 07:32 PM)xiphirx Wrote: Try disabling motion blur. If I understand correctly from the log, your card doesn't support it...
Motion blur is/was disabled. Changing the settings doesn't change the outcome.

(11-22-2010, 04:46 PM)davva Wrote: i don't know shit about HPL logs but it looks like you're missing some files, try to reinstall the game (just make sure that you make a backup for your saved games rofl. if you do reinstall it that is^^)
I already re-installed it 3x before I posted it here to see if it was an install error.
11-23-2010, 10:00 PM
Find
KavazovAngel Offline
Member

Posts: 161
Threads: 13
Joined: Jul 2010
Reputation: 0
#10
Solved: 2 Years, 3 Months, 3 Weeks ago RE: Textures keep changing while moving around

Try disabling any postprocessing related graphics options like motionblur / depth of field / particle effect and similar stuff.
11-28-2010, 08:09 PM
Find




Users browsing this thread: 1 Guest(s)