Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cannot Open 05_02_ARK_inside.hpm
Nerd in a Box
Unregistered

 
#1
Not Solved Cannot Open 05_02_ARK_inside.hpm
Hello all!

So I am a fairly avid HPL3 Modder and I have been working on my SOMA campaign for well over six months now. I have come to a point in the campaign that I want to make an outside level map, much like the ARK in the original game, so I wanted to see how Frictional did it themselves with the map settings and other stuff. However, whenever I try to load up 05_02_ARK_inside.hpm, it instantly crashes and I am unable to view the map itself. This also happens with any map that has a terrain such as 02_01_ms_curie_outside.hpm, but I am able to turn the terrain off to bypass this issue when the map loads (since the terrain is higher up and it crashes when the terrain comes into view of the camera), but now I can't even get on this map. I've posted part of my HPL3 Log below if that helps at all, any help would be outstanding! If you need more of it I can do that.

Thanks in advance!

Quote:Game Running
--------------------------------------------------------

---------------------------------------------------------------------------------------------------------------------------------------------------------
-- Loading scene: C:/Program Files (x86)/Steam/steamapps/common/SOMA/maps/chapter05/05_02_ARK_inside/05_02_ARK_inside.hpm
---------------------------------------------------------------------------------------------------------------------------------------------------------

Resetting editor...
Failed parsing of XML document C:/Users/*****/Documents/HPL3/Sessions/AFF0228DF90A54FCE9D5A341CF0950C6BC3407F9.hpm_session: file not found
ERROR: Could not open file C:/Program Files (x86)/Steam/steamapps/common/SOMA/maps/chapter05/05_02_ARK_inside/05_02_ARK_inside.hpm_Terrain_diffusecolorblend.png for reading!
Loading FileIndex: TerrainDecals ...found
Loading FileIndex: UndergrowthMaterials ...found
Loading FileIndex: TerrainDecals ...found
Loading FileIndex: UndergrowthMaterials ...found
Loading FileIndex: TerrainDecals ...found
Loading FileIndex: UndergrowthMaterials ...found
Loading FileIndex: TerrainDecals ...found
Loading FileIndex: UndergrowthMaterials ...found
Failed parsing of XML document undergrowth/plants/red_flower/undergrowth_flower_red.tum: Error document empty. in line 0, column 0
Loading FileIndex: TerrainDecals ...found
Loading FileIndex: UndergrowthMaterials ...found
Loading FileIndex: TerrainDecals ...found
Loading FileIndex: UndergrowthMaterials ...found
Loading FileIndex: TerrainDecals ...found
Loading FileIndex: UndergrowthMaterials ...found
Loading FileIndex: TerrainDecals ...found
Failed parsing of XML document C:/Program Files (x86)/Steam/steamapps/common/SOMA/textures/terrain/decals/sand_darkener.mat: Error document empty. in line 0, column 0
ERROR: Couldn't load material 'textures/terrain/decals/sand_darkener.mat'
Failed parsing of XML document C:/Program Files (x86)/Steam/steamapps/common/SOMA/textures/terrain/decals/sand_darkener.mat: Error document empty. in line 0, column 0
ERROR: Couldn't load material 'textures/terrain/decals/sand_darkener.mat'
Failed parsing of XML document C:/Program Files (x86)/Steam/steamapps/common/SOMA/textures/terrain/decals/sand_darkener.mat: Error document empty. in line 0, column 0
ERROR: Couldn't load material 'textures/terrain/decals/sand_darkener.mat'
Failed parsing of XML document C:/Program Files (x86)/Steam/steamapps/common/SOMA/textures/terrain/decals/sand_darkener.mat: Error document empty. in line 0, column 0
ERROR: Couldn't load material 'textures/terrain/decals/sand_darkener.mat'
Failed parsing of XML document C:/Program Files (x86)/Steam/steamapps/common/SOMA/textures/terrain/decals/sand_darkener.mat: Error document empty. in line 0, column 0
ERROR: Couldn't load material 'textures/terrain/decals/sand_darkener.mat'
Loading FileIndex: UndergrowthMaterials ...found
Loading FileIndex: TerrainDecals ...found
Loading FileIndex: UndergrowthMaterials ...found
Loading FileIndex: TerrainDecals ...found
Loading FileIndex: UndergrowthMaterials ...found
 Creating DetailMesh: detail_meshes/flowers/flower_violette_single.DAE
 Creating DetailMesh: detail_meshes/rocks/small_rocks_forest/small_rocks_forest_single.DAE
 Creating DetailMesh: detail_meshes/rocks/small_rocks_forest/small_rocks_forest_multiple.DAE
 Creating DetailMesh: detail_meshes/rocks/small_rocks_abyss/small_rocks_abyss_single01.dae
 Creating DetailMesh: detail_meshes/rocks/small_rocks_forest/small_rocks_forest_multiple.DAE
WARNING:   DetailMesh was already present. Merging contents...
 Creating DetailMesh: detail_meshes/rocks/small_rocks_forest/small_rocks_forest_single.DAE
WARNING:   DetailMesh was already present. Merging contents...
 Creating DetailMesh: detail_meshes/rocks/small_rocks_forest/small_rocks_forest_single.DAE
WARNING:   DetailMesh was already present. Merging contents...
 Creating DetailMesh: detail_meshes/rocks/small_rocks_forest/small_rocks_forest_multiple.DAE
WARNING:   DetailMesh was already present. Merging contents...
Loading FileIndex: StaticObjects ...found
Loading FileIndex: StaticObjects ...found
Loading FileIndex: StaticObjects ...found
Loading FileIndex: StaticObjects ...found
Loading FileIndex: StaticObjects ...found
Loading FileIndex: StaticObjects ...found
Loading FileIndex: StaticObjects ...found
Loading FileIndex: StaticObjects ...found
Loading FileIndex: StaticObjects ...found
Loading FileIndex: StaticObjects ...found
Loading FileIndex: Entities ...found
ERROR: Indexed file 'entities/_temp/anton/anton_vegetation/anton_trees/anton_birch.ent' not found
ERROR: Could not create indexed file, map might not be correct
ERROR: Indexed file 'entities/_temp/anton/anton_vegetation/anton_trees/anton_oak_a.ent' not found
ERROR: Could not create indexed file, map might not be correct
ERROR: Indexed file 'entities/_temp/anton/anton_vegetation/anton_trees/anton_spruce_a.ent' not found
ERROR: Could not create indexed file, map might not be correct
Loading FileIndex: Entities ...found
Loading FileIndex: Entities ...found
Loading FileIndex: Entities ...found
Loading FileIndex: Entities ...found
ERROR: Indexed file 'entities/_temp/aaron/waterplane_05_02.ent' not found
ERROR: Could not create indexed file, map might not be correct
WARNING: Sub mesh 'marker_waterfall' does not exist in mesh 'water_fx_05_02_stream.msh'!
WARNING: Sub mesh 'marker_cath' does not exist in mesh 'water_fx_05_02_stream.msh'!
WARNING: Sub mesh 'marker_waterfall' does not exist in mesh 'water_fx_05_02_stream.msh'!
WARNING: Sub mesh 'marker_cath' does not exist in mesh 'water_fx_05_02_stream.msh'!
Loading FileIndex: Entities ...found
Loading FileIndex: Entities ...found
Loading FileIndex: Entities ...found
Loading FileIndex: Entities ...found
Loading FileIndex: Entities ...found
Loading FileIndex: Decals ...found
WARNING: Decal moss_patchy_3 is missing geometry, skipping!
Loading FileIndex: Decals ...found
Loading FileIndex: Decals ...found
Loading FileIndex: Decals ...found
Loading FileIndex: Decals ...found
Loading FileIndex: Decals ...found
Loading FileIndex: Decals ...found
Loading FileIndex: Decals ...found
Loading FileIndex: Decals ...found
Loading FileIndex: Decals ...found

---------------------------------------------------------------------------------------------------------------------------------------------------------
-- Done loading scene
---------------------------------------------------------------------------------------------------------------------------------------------------------

WARNING: Material '' has no base mesh, cannot create undergrowth.
WARNING: Material '' has no base mesh, cannot create undergrowth.
WARNING: Material '' has no base mesh, cannot create undergrowth.
WARNING: Material '' has no base mesh, cannot create undergrowth.


 - Nerd in a Box -
01-01-2019, 06:44 PM
Reply
TiManGames Offline
Senior Member

Posts: 496
Threads: 22
Joined: May 2015
Reputation: 11
#2
Not Solved RE: Cannot Open 05_02_ARK_inside.hpm
Open 05_02_ARK_inside.hpm in a text editor, for example Notepad++
Delete all the content inside between <RegisteredUsers> and </RegisteredUsers>
If it still crashes, delete <RegisteredUsers> and </RegisteredUsers> too.

(This post was last modified: 01-01-2019, 06:55 PM by TiManGames.)
01-01-2019, 06:54 PM
Find Reply
Nerd in a Box
Unregistered

 
#3
Not Solved RE: Cannot Open 05_02_ARK_inside.hpm
Hi! Thanks for the quick reply!

I tried what you told me, even deleted the <RegisteredUser> stuff too, but the problem still persists. I restarted my laptop, put the items back into the .hpm file, deleted them again, but it still continues. Any other ideas? Thanks!
01-01-2019, 07:16 PM
Reply
TiManGames Offline
Senior Member

Posts: 496
Threads: 22
Joined: May 2015
Reputation: 11
#4
Not Solved RE: Cannot Open 05_02_ARK_inside.hpm
(01-01-2019, 07:16 PM)Nerd in a Box Wrote: Hi! Thanks for the quick reply!

I tried what you told me, even deleted the <RegisteredUser> stuff too, but the problem still persists. I restarted my laptop, put the items back into the .hpm file, deleted them again, but it still continues. Any other ideas? Thanks!

What are you laptop specs?

(This post was last modified: 01-01-2019, 07:31 PM by TiManGames.)
01-01-2019, 07:31 PM
Find Reply
Nerd in a Box
Unregistered

 
#5
Not Solved RE: Cannot Open 05_02_ARK_inside.hpm
I think this is what you requested but ¯\_(ツ)_/¯


.png   spec1.png (Size: 142.16 KB / Downloads: 4)
01-01-2019, 07:51 PM
Reply
Nerd in a Box
Unregistered

 
#6
Not Solved RE: Cannot Open 05_02_ARK_inside.hpm
Okay so I kind of got it to open but I still have the issue about when the terrain is active. I had opened 05_02_ARK_inside.hpm_Terrain and turned the terrain off manually, so I can open the map now. If anyone has any insight on how to get the map open with the terrain active it would be wonderful!
01-01-2019, 08:29 PM
Reply
TiManGames Offline
Senior Member

Posts: 496
Threads: 22
Joined: May 2015
Reputation: 11
#7
Not Solved RE: Cannot Open 05_02_ARK_inside.hpm
(01-01-2019, 07:51 PM)Nerd in a Box Wrote: I think this is what you requested but ¯\_(ツ)_/¯

What is your graphics card?
The terrain may crash because the editor sometimes gets glitch with certain cards.

01-01-2019, 08:49 PM
Find Reply
Nerd in a Box
Unregistered

 
#8
Not Solved RE: Cannot Open 05_02_ARK_inside.hpm
Intel® HD Graphics 5500
01-01-2019, 09:01 PM
Reply
TiManGames Offline
Senior Member

Posts: 496
Threads: 22
Joined: May 2015
Reputation: 11
#9
Not Solved RE: Cannot Open 05_02_ARK_inside.hpm
(01-01-2019, 09:01 PM)Nerd in a Box Wrote: Intel® HD Graphics 5500

This is potentially the problem
Your Graphical card is weak and barely meets the minimum requirements for the game.

01-02-2019, 08:00 AM
Find Reply
Mudbill Offline
Muderator

Posts: 3,766
Threads: 59
Joined: Apr 2013
Reputation: 174
#10
Not Solved RE: Cannot Open 05_02_ARK_inside.hpm
Barely? It is actually unsupported altogether. Some Intel cards may work, but none of them are supported by FG in the minimum specs.

01-05-2019, 08:17 PM
Find Reply
Jump to the post that solved this thread.


[-]
Quick Reply
Message
Type your reply to this message here.

Human Verification
Please tick the checkbox that you see below. This process is used to prevent automated spam bots.



Users browsing this thread: 1 Guest(s)