Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Low FPS in main menu
hamongnguyet Offline
Junior Member

Posts: 1
Threads: 1
Joined: Jan 2019
Reputation: 0
Not Solved Low FPS in main menu

Hi there,

I just started playing this game SOMA and having this low FPS issue on my laptop. I think my laptop is capable of running this game smoothly but I am having ~30 FPS in main menu and game-play and it was not smooth at all.

-64 bit Win10 i7-7500U Nvidia GTX 950M (Driver up-to-date)
-Changing graphic quality from "high" to "low" or "off" doesn't help
-Changed Engine LimitFPS="false" already
-My default resolution is 1920*1080. When I changed the resolution to 1600*900 or below my FPS was 150+ but I could not make the game run in full screen

Attached is my HPL.log file and thank you in advance! 
01-23-2019, 05:37 PM
Find Reply
Darkfire Offline
Senior Member

Posts: 360
Threads: 21
Joined: May 2014
Reputation: 15
Not Solved RE: Low FPS in main menu

What is the resolution and refresh rate of your laptops screen ?
When you run it in <1600*900 does it run in a small window ?
Are you sure you attached the log ? I can't see it anywhere.

Keep in mind that ~30 fps isn't bad for this game at all. HPL3 is an engine which came from an old home-brew engine, and takes it's possibilities to the max. The result of this is that SOMA is quite unstable.
It's been reported that the game stutters regardless of settings and computer's power. Happened to me as well - some sections would run smoothly, and then I look behind a corner and framerate drops to less than 20.

You might be better off just putting the framerate cap back on and bearing with 30FPS. It's not like you will need the extra frames to react faster in this game ¯\_(ツ)_/¯

(This post was last modified: 01-23-2019, 06:36 PM by Darkfire.)
01-23-2019, 06:32 PM
Find Reply
Mudbill Offline

Posts: 3,772
Threads: 59
Joined: Apr 2013
Reputation: 174
Not Solved RE: Low FPS in main menu

Turn vsync off if you can. I think I had a similar issue with vsync hopping to 30 if you cant maintain a solid 60.

01-24-2019, 01:38 AM
Find Reply

Quick Reply
Type your reply to this message here.

Human Verification
Please tick the checkbox that you see below. This process is used to prevent automated spam bots.

Users browsing this thread: 1 Guest(s)