Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


(RESOLVED) Penumbra Performance Problems?
MercenaryForHire Offline
Junior Member

Posts: 41
Threads: 4
Joined: Jan 2007
Reputation: 0
#11
Solved: 4 Years, 4 Months, 2 Weeks ago RE: Penumbra Performance Problems?

tedy Wrote:raven i have 93.71: you think i should change drivers?

"If it ain't broke, don't fix it."

If you're having performance issues in Penumbra that you can't blame anything else for, give it a shot. You could wait until I try it if you don't feel like being the guinea pig though. Wink
04-09-2007, 09:14 PM
Find
SirRaven Offline
Junior Member

Posts: 34
Threads: 0
Joined: Apr 2007
Reputation: 0
#12
Solved: 4 Years, 4 Months, 2 Weeks ago RE: Penumbra Performance Problems?

tedy Wrote:raven i have 93.71: you think i should change drivers?

I'd recommend it. However, first see what results Mercenary has since he is going to give it a try. I am speaking from personal experience with the new drivers and I believe it would be a worthy attempt. I don't know what nvidia did but I was getting horrid results with it in Splinter Cell: Double Agent and i was getting erratic gpu fan speeds. 93.71 was also causing my gpu fan to crank up to max speed when I went into standby mode. In fact, when 93.71 first came out, I upgraded to them and instantly saw the decrease in performance w/ Splinter Cell. Then I downgraded back to 84.21. Later I had graphical issues in a newer game and upgraded to find the same issues and realize the whole problem was resolution-related (I editted 1440x900 in the wrong config). Then I discovered the fan problems and decided to banish those drivers forever and reinstall 84.21. These drivers have served me well no matter how new the game.

I am pretty confident it is driver related. Like the above said, if your out of ideas...it's worth a shot, only takes a couple of minutes to uninstall/install vid drivers. Just as mercenary also mentioned "if it ain't broke, don't fix it". I can't begin to describe how true that is for video drivers. Even if you are using old drivers, if they are doing great...don't bother upgrading.
04-09-2007, 09:33 PM
Find
MercenaryForHire Offline
Junior Member

Posts: 41
Threads: 4
Joined: Jan 2007
Reputation: 0
#13
Solved: 4 Years, 4 Months, 2 Weeks ago RE: Penumbra Performance Problems?

MercenaryForHire Wrote:
tedy Wrote:raven i have 93.71: you think i should change drivers?

"If it ain't broke, don't fix it."

If you're having performance issues in Penumbra that you can't blame anything else for, give it a shot. You could wait until I try it if you don't feel like being the guinea pig though. Wink

Well, on the upside, Penumbra's performance took a healthy jump. Framerates now bottom out at 10fps in combat - non-combat is hovering around 20-30fps.

On the downside, I no longer seem to have automatic fan control.
04-09-2007, 10:52 PM
Find
SirRaven Offline
Junior Member

Posts: 34
Threads: 0
Joined: Apr 2007
Reputation: 0
#14
Solved: 4 Years, 4 Months, 2 Weeks ago RE: Penumbra Performance Problems?

MercenaryForHire Wrote:Well, on the upside, Penumbra's performance took a healthy jump. Framerates now bottom out at 10fps in combat - non-combat is hovering around 20-30fps.

On the downside, I no longer seem to have automatic fan control.

hmm, your fan should be revving up when the game starts to max power and rev down when out of game. What is it doing in particular? Also check your temperature settings. This symptom sounds like you have a dead fan somewhere causing cooling problems. That could be another reason for bad performance. Your card could be overheating due to a blown fan. Another problem could be a dead case fan that is allowing your CPU to overheat.

I remember when I used to play WoW, I started having real poor performance after looking inside my tower, I noticed that my main fan connected to the powersupply had burnt out. I used to get 60-70fps and after, I was getting 1-5fps because my CPU was overheating.
04-10-2007, 12:24 AM
Find
MercenaryForHire Offline
Junior Member

Posts: 41
Threads: 4
Joined: Jan 2007
Reputation: 0
#15
Solved: 4 Years, 4 Months, 2 Weeks ago RE: Penumbra Performance Problems?

SirRaven Wrote:hmm, your fan should be revving up when the game starts to max power and rev down when out of game. What is it doing in particular? Also check your temperature settings. This symptom sounds like you have a dead fan somewhere causing cooling problems. That could be another reason for bad performance. Your card could be overheating due to a blown fan. Another problem could be a dead case fan that is allowing your CPU to overheat.
It just runs full bore 100% of the time. I can ramp it down via RivaTuner, but it doesn't automatically clock back down to 2D speeds.

Quote:I remember when I used to play WoW, I started having real poor performance after looking inside my tower, I noticed that my main fan connected to the powersupply had burnt out. I used to get 60-70fps and after, I was getting 1-5fps because my CPU was overheating.
Temps are fine, CPU never breaks 50C under load.
04-10-2007, 02:48 AM
Find
SirRaven Offline
Junior Member

Posts: 34
Threads: 0
Joined: Apr 2007
Reputation: 0
#16
Solved: 4 Years, 4 Months, 2 Weeks ago RE: Penumbra Performance Problems?

That's really weird the 100% fan speed problem I've heard being attributed to Vista but never to XP. Well at least there's still the good news that performance has increased. Still would like to get those other issues fixed for ya though.
04-10-2007, 05:51 PM
Find
SpannerMagnet Offline
Junior Member

Posts: 23
Threads: 1
Joined: Apr 2007
Reputation: 0
#17
Solved: 4 Years, 4 Months, 2 Weeks ago RE: (RESOLVED) Penumbra Performance Problems?

I use 93.71 on my 7800GT (256MB) and it runs perfectly. Haven't tried the game with AA. Speaking of which, I'll try that now.

"I never felt truly alive until I was staring death in the face"
04-16-2007, 05:37 PM
Find
preifx Offline
Junior Member

Posts: 9
Threads: 0
Joined: Apr 2007
Reputation: 0
#18
Solved: 4 Years, 4 Months, 2 Weeks ago RE: (RESOLVED) Penumbra Performance Problems?

I unstalled 93.71 and reinstalled 84.21, but still having the problem, it's not the problem of the driver I think, because I didn't have any problems in other games with 93.71.
04-20-2007, 03:35 PM
Find




Users browsing this thread: 1 Guest(s)