Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Running Amnesia without S3TC compression?
nobled Offline
Junior Member

Posts: 1
Threads: 1
Joined: Aug 2011
Reputation: 0
Solved: 4 Years, 5 Months, 1 Week ago Running Amnesia without S3TC compression?

I downloaded the Amnesia demo (the installer filename says version 1.0.1... seems kinda old?), and I'm trying to run it in 64-bit Ubuntu 11.04, with the integrated Sandybridge GPU in my laptop.

Unfortunately, based on using apitrace to debug it, it seems like Amnesia is calling glCompressedTexImage2D() with internalFormat=GL_COMPRESSED_S3TC_DXT1_EXT, even though GL_EXT_texture_compression_s3tc isn't advertised in the extension string by the Intel graphics driver. (I'm using the latest version I can, installed from the xorg-edgers repository.)

Is it possible to run without s3tc compression? If it isn't, can't Amnesia exit with a useful error message when it isn't advertised?

I'm assuming this is the issue that's filling up my hpl.log (attached) with lines like this:
ERROR: Couldn't load material 'entities/lamp/torch_static01/torch_static01.mat'
ERROR: Could not create GL texture /opt/AmnesiaDemo/particles/materials/ps_torch_fire.dds

Attached Files
.log   hpl.log (Size: 10.22 KB / Downloads: 21)
08-13-2011, 03:41 PM
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
Solved: 4 Years, 5 Months, 1 Week ago RE: Running Amnesia without S3TC compression?

S3TC is required for Amnesia to run, you can installed the libtxc_dxtn library which will add support for S3TC into Mesa GL


However since you are running an Intel graphics card there is still not guarantee that Amnesia will run.

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
08-13-2011, 03:50 PM
Website Find

Users browsing this thread: 1 Guest(s)