Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Amnesia needs libfltk == 1.1 (current is 1.3)
breversa Offline
Junior Member

Posts: 2
Threads: 1
Joined: Aug 2011
Reputation: 0
#1
Solved: 3 Years, 7 Months, 3 Weeks ago Bug  [SOLVED] Amnesia needs libfltk == 1.1 (current is 1.3)

Hi there,

When I purchased Amnesia in december 2010, it ran flawlessly on my Linux box (OpenSUSE 11.3 x86_64).

However, when I started it again today, it failed to launch with the following error :
$>/usr/local/games/Amnesia> ./Launcher.bin64
./Launcher.bin64: error while loading shared libraries: libfltk.so.1.1: cannot open shared object file: No such file or directory

I checked my libfltk version, which had actually been upgraded to 1.3 inbetween. Downgrading to 1.1 solved the problem, but I'm concerned : won't Amnesia fail to run on current/newer distributions because of this ?

Can it be patched so that it requires "libfltk >= 1.1" instead of "== 1.1" ? Otherwise, it may conflict with more recent applications that would require 1.3+...
(This post was last modified: 08-18-2011, 08:33 PM by breversa.)
08-18-2011, 05:39 PM
Find
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
#2
Solved: 3 Years, 7 Months, 3 Weeks ago RE: Amnesia needs libfltk == 1.1 (current is 1.3)

First, fltk 1.1 is not binary compatible with fltk 1.3. so doing a >= won't work..

What you can do is upgrade your system FLTK to 1.3, and then run the "checklibs64.sh" script that is in the game directory.

This will re-scan your system for libraries and if your system does not provide a certain library it will link it in from the Amnesia/lib64/all folder (as included in the distribution is libfltk.so.1.1)

This script is automatically run when you install the game, so re-installing the game would seem to magically "solve" the problem.

Now, the reason for not always using the game provided libraries is that more often the system libraries work better.. This is especially true for SDL and openal.


Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
08-18-2011, 06:45 PM
Website Find
breversa Offline
Junior Member

Posts: 2
Threads: 1
Joined: Aug 2011
Reputation: 0
#3
Solved: 3 Years, 7 Months, 3 Weeks ago RE: Amnesia needs libfltk == 1.1 (current is 1.3)

Hi Urkle, and thanks for your quick reply. :-)

I didn't know that 1.1 and 1.3 were not compatible, but re-running the checklibs64.sh after upgrading to 1.3 does fix the problem. Thanks ! :-)
08-18-2011, 08:32 PM
Find




Users browsing this thread: 1 Guest(s)