Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Scripting fatal errors?
Rapsis Offline
Member

Posts: 69
Threads: 6
Joined: Oct 2012
Reputation: 0
#81
RE: Scripting fatal errors?

(08-07-2013, 11:21 AM)Kreekakon Wrote:
(08-07-2013, 11:18 AM)Rapsis Wrote: But I'm using a sound already included in-game, I don't think I should change it.
Well, you could make a copy of the sound file along with its .snt, give them different names, and put it along with your other custom story files. That way you can alter them without any fear of messing with the main game.

Tried that, and the sound doesn't work at all now:

<SOUNDENTITY>
<SOUNDS>
<Main>
<Sound File="breathrun.ogg" />
</Main>
</SOUNDS>
<PROPERTIES Volume="1" MinDistance="1" MaxDistance="10" Random="1" Interval="0" FadeEnd="False" FadeStart="False" Stream="False" Loop="True" Use3D="True" Blockable="True" BlockVolumeMul="0.7" Priority="0" />
</SOUNDENTITY>

this used to work before; I'll try tinkering with it later, I'm going out.
08-07-2013, 11:26 AM
Find Reply
Rapsis Offline
Member

Posts: 69
Threads: 6
Joined: Oct 2012
Reputation: 0
#82
RE: Scripting fatal errors?

Nope, can't figure it out. Here's the script and the soundentity:
void OnStart()
{
    PlaySoundAtEntity("breathrun.ogg", "breathrun.snt", "Player", 1, false);
    PreloadSound("breathrun.snt");
}


<SOUNDENTITY>
  <SOUNDS>
      <Main>
          <Sound File="breathrun.ogg" />
      </Main>
  </SOUNDS>
  <PROPERTIES Volume="1" MinDistance="1" MaxDistance="10" Random="0" Interval="0" FadeEnd="False" FadeStart="False" Stream="False" Loop="True" Use3D="True" Blockable="True" BlockVolumeMul="0.7" Priority="0" />
</SOUNDENTITY>
(This post was last modified: 08-07-2013, 03:13 PM by Rapsis.)
08-07-2013, 03:12 PM
Find Reply
The chaser Offline
Posting Freak

Posts: 2,486
Threads: 76
Joined: Jun 2012
Reputation: 113
#83
RE: Scripting fatal errors?

(08-07-2013, 03:12 PM)Rapsis Wrote: Nope, can't figure it out. Here's the script and the soundentity:
void OnStart()
{
    PlaySoundAtEntity("breathrun.ogg", "breathrun.snt", "Player", 1, false);
    PreloadSound("breathrun.snt");
}


<SOUNDENTITY>
  <SOUNDS>
      <Main>
          <Sound File="breathrun.ogg" />
      </Main>
  </SOUNDS>
  <PROPERTIES Volume="1" MinDistance="1" MaxDistance="10" Random="0" Interval="0" FadeEnd="False" FadeStart="False" Stream="False" Loop="True" Use3D="True" Blockable="True" BlockVolumeMul="0.7" Priority="0" />
</SOUNDENTITY>

void OnStart()
{
    PlaySoundAtEntity("breathrun", "breathrun.snt", "Player", 1, false);
    PreloadSound("breathrun.snt");
}



Try this script, perhaps it works.

THE OTHERWORLD (WIP)
[Image: k6vbdhu]

Aculy iz dolan.
08-07-2013, 03:20 PM
Find Reply
Rapsis Offline
Member

Posts: 69
Threads: 6
Joined: Oct 2012
Reputation: 0
#84
RE: Scripting fatal errors?

(08-07-2013, 03:20 PM)The chaser Wrote: Try this script, perhaps it works.

I literally copy/pasted it into my script and it still doesn't work.
(This post was last modified: 08-07-2013, 03:25 PM by Rapsis.)
08-07-2013, 03:23 PM
Find Reply
The chaser Offline
Posting Freak

Posts: 2,486
Threads: 76
Joined: Jun 2012
Reputation: 113
#85
RE: Scripting fatal errors?

Is there any .map_cache file in your map? In that case, delete it. If that doesn't work, I'm out of ideas...

THE OTHERWORLD (WIP)
[Image: k6vbdhu]

Aculy iz dolan.
08-07-2013, 03:33 PM
Find Reply
Rapsis Offline
Member

Posts: 69
Threads: 6
Joined: Oct 2012
Reputation: 0
#86
RE: Scripting fatal errors?

(08-07-2013, 03:33 PM)The chaser Wrote: Is there any .map_cache file in your map? In that case, delete it. If that doesn't work, I'm out of ideas...

Nope, no map cache. What's weird is that I've done the same thing before on another map and it worked.





Wow, only that one specific sound doesn't play. It was react_breath. What the hell?





Can someone explain why why that specific sound doesn't work while every other one does?!? It's so annoying!

Wow, I'm going to fucking explode. I've been trying to fix this piece of shit for at least 4 hours with no fucking avail. Why can't it fucking work right!?
(This post was last modified: 08-07-2013, 04:32 PM by Rapsis.)
08-07-2013, 03:35 PM
Find Reply
Rapsis Offline
Member

Posts: 69
Threads: 6
Joined: Oct 2012
Reputation: 0
#87
RE: Scripting fatal errors?

Alright, I got it to fucking work, but it's not looping. I guess I'll try making a fucking timer or some shit like that

I fucking did it. I'm a motherfucking genius.

How do I make the StartEffectFlash stay at white for longer? afFadeIn doesn't seem to be doing anything at all, and afFadeOut changes how fast it both fades in AND out.
(This post was last modified: 08-07-2013, 04:57 PM by Rapsis.)
08-07-2013, 04:39 PM
Find Reply




Users browsing this thread: 1 Guest(s)