Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem Running Editor On OS X 10.10.1
Stolas Offline
Junior Member

Posts: 13
Threads: 2
Joined: Dec 2014
Reputation: 0
#1
Solved: 2 Years, 9 Months, 1 Week ago Problem Running Editor On OS X 10.10.1

I'm having a huge issue.
After days of hard work,
I can no longer use the editor suite.
Previously, I had to wrestle with it to make it work,
but it did work with effort.
The mac editor installer did not work, so I had to manual install.
Then, I had to paste and overwrite all the editor files every time I used it.
But yesterday, I went to reinstall and open the editor,
and I got an alert.

LevelEditor cannot be opened because of a problem.
Check with your developer to make sure LevelEditor works with this version of OS X.
Be sure to install any available updates for the application and OS X.

(I will put the Problem Details and System Configuration below)

I am running the Steam version of Amnesia.

So I tried restarting.
the I tried reinstalling, both manually, and with the installer.
I tried restarting again.
I tried uninstalling the game, restarting, reinstalling the game, restarting,
reinstalling the Editor Suite, (with all available methods for mac)
and restarting.
I have tried uninstalling Steam, reinstalling,
and of course, restarting.
I've also tried running all editors, both from the launcher tab and directly.

I'm running:
OS X Yosemite Version 10.10.1
iMac (27-inch, Late 2009)
2.66 GHz Intel Core i5
4 GB 1067 MHz DDR3
ATI Radeon HD 4850 512 MB

The version should not be the issue,
as I was successfully running the editor on this version previous to the problem.
As far as I know, there have been no kind of updates to anything on my system,
including the game itself, that would be the cause to my problem.
If there was any kind of update to anything, I was never prompted or alerted.

The game itself runs perfectly,
I have had absolutely no issue playing Amnesia.
So as far as I can gather, it has nothing to do with system requirements,
such as the graphics card.

I have tried searching these forums and many, many other places on the net.
I hope I have posted sufficient information as to my problem,
the measures I have taken to solve it, and my system.

here is the Problem Details report that I recieve with the message.
Process: LevelEditor [444]
Path: /Users/USER/Library/Application Support/Steam/*/LevelEditor.app/Contents/MacOS/LevelEditor
Identifier: com.frictionalgames.HPL2.LevelEditor
Version: ???
Code Type: X86 (Native)
Parent Process: ??? [1]
Responsible: LevelEditor [444]
User ID: 501

Date/Time: 2014-12-07 00:48:27.113 -0500
OS Version: Mac OS X 10.10.1 (14B25)
Report Version: 11
Anonymous UUID: 647CD23A-6F6E-13D0-1A1B-DD4043477883


Time Awake Since Boot: 23000 seconds

Crashed Thread: 0

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries
DYLD_LIBRARY_PATH=
DYLD_INSERT_LIBRARIES=/Applications/Steam.app/Contents/MacOS/gameoverlayrenderer.dylib:/Applications/Steam.app/Contents/MacOS/steamloader.dylib
DYLD_FALLBACK_LIBRARY_PATH=/Applications/Steam.app/Contents/MacOS:/Users/macosx/Library/Application Support/Steam/steamapps/common/Amnesia The Dark Descent:/Users/macosx/Library/Application Support/Steam/steamapps/common/Amnesia The Dark Descent/bin:/usr/local/lib:/lib:/usr/lib

Dyld Error Message:
Library not loaded: @executable_path/../Frameworks/ALUT.framework/Versions/A/ALUT
Referenced from: /Users/USER/Library/Application Support/Steam/*/LevelEditor.app/Contents/MacOS/LevelEditor
Reason: image not found

Binary Images:
0x8fe31000 - 0x8fe64e03 dyld (353.2.1) <EBFF7998-58E8-32F5-BF0D-9690278EC792> /usr/lib/dyld
0x913ae000 - 0x913aefff com.apple.Carbon (154 - 157) <5A078967-8437-3721-A6B1-70CC00461D7B> /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon

Model: iMac11,1, BootROM IM111.0034.B02, 4 processors, Intel Core i5, 2.66 GHz, 4 GB, SMC 1.54f36
Graphics: ATI Radeon HD 4850, ATI Radeon HD 4850, PCIe, 512 MB
Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1067 MHz, 0x80AD, 0x484D54313235533642465238432D47372020
Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1067 MHz, 0x80AD, 0x484D54313235533642465238432D47372020
AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x8F), Atheros 9280: 4.0.74.0-P2P
Bluetooth: Version 4.3.1f2 15015, 3 services, 27 devices, 1 incoming serial ports
Network Service: AirPort, AirPort, en1
Serial ATA Device: ST31000528AS, 1 TB
Serial ATA Device: OPTIARC DVD RW AD-5680H
USB Device: Hub
USB Device: G13
USB Device: Internal Memory Card Reader
USB Device: BRCM2046 Hub
USB Device: Bluetooth USB Host Controller
USB Device: Hub
USB Device: Logitech Extreme 3D
USB Device: IR Receiver
USB Device: Built-in iSight
Thunderbolt Bus:



Please, somebody help me.
Up til now,
I have had to struggle so hard just to get the editor to work,
Searching the web for answers because there is little help for mac owners.
I finally get the editor to work, and this happens.
I am extremely frustrated that all my work is lost.
If anybody can help, I would be extremely thankful.
(This post was last modified: 12-07-2014, 07:27 AM by Stolas.)
12-07-2014, 07:25 AM
Find
Mudbill Offline
Muderator

Posts: 3,733
Threads: 59
Joined: Apr 2013
Reputation: 173
#2
Solved: 2 Years, 9 Months, 1 Week ago RE: Problem Running Editor On OS X 10.10.1

The editors were never actually updated to support OS X 10.9 and 10.10, so you're lucky you got them to run at all. I agree this should be fixed ASAP, because this incompatibility has been around for over a year now. Perhaps the 1.3 update will properly fix this.

Yes, there was an update to Amnesia just a few days ago (I think the update was given to Mac users as well, but not the new editors yet). That might have something to do with it. Once the new 1.3 editors are released, we can only hope they support the new OS X versions.

12-07-2014, 05:01 PM
Find
Stolas Offline
Junior Member

Posts: 13
Threads: 2
Joined: Dec 2014
Reputation: 0
#3
Solved: 2 Years, 9 Months, 1 Week ago RE: Problem Running Editor On OS X 10.10.1

Ah, there was an update.
I really wish I was prompted first, given a choice.
I'm gathering that a 1.3 editor update is just speculation?
I would just roll back my os but I have other games that won't run if I do.
Of course, this is an old game.
I guess at this point they could just stop development and move on.

Is there a way to uninstall the latest update on the steam version?
(This post was last modified: 12-07-2014, 06:13 PM by Stolas.)
12-07-2014, 06:01 PM
Find
Mudbill Offline
Muderator

Posts: 3,733
Threads: 59
Joined: Apr 2013
Reputation: 173
#4
Solved: 2 Years, 9 Months, 1 Week ago RE: Problem Running Editor On OS X 10.10.1

Not that I know of.

One thing I do know is that the editors is not just a speculation. Jens confirmed them to be released soon here.

(This post was last modified: 12-07-2014, 10:54 PM by Mudbill.)
12-07-2014, 10:54 PM
Find
Stolas Offline
Junior Member

Posts: 13
Threads: 2
Joined: Dec 2014
Reputation: 0
#5
Solved: 2 Years, 9 Months, 1 Week ago RE: Problem Running Editor On OS X 10.10.1

Awesome. That's great news! Hopefully that will fix my issue.

Also... do you get paid, mudbill? Lol
One-man support team!
12-07-2014, 11:21 PM
Find
Mudbill Offline
Muderator

Posts: 3,733
Threads: 59
Joined: Apr 2013
Reputation: 173
#6
Solved: 2 Years, 9 Months, 1 Week ago RE: Problem Running Editor On OS X 10.10.1

I get paid appreciation Smile

12-07-2014, 11:51 PM
Find




Users browsing this thread: 1 Guest(s)