Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


64-bit Archlinux using 32-bit chrooted environment, game fails to start
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
#11
Solved: 2 Years, 7 Months, 2 Weeks ago RE: 64-bit Archlinux using 32-bit chrooted environment, game fails to start
the items dissapearing may be caused by the newer ATI drivers (windows users have encountered similar issues I believe). I have a patch on the way to address those (hopefully)

As for the door.. yup it's a blocked door.. look around more you'll find another way (and find out what's blocking the door)

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
07-26-2009, 11:24 PM
Website Find
DigitalPioneer
Unregistered

 
#12
Solved: 2 Years, 7 Months, 2 Weeks ago RE: 64-bit Archlinux using 32-bit chrooted environment, game fails to start
Actually, I saw there was a barrel blocking the door before I got through it because the wall disappeared and I looked in. LOL

In the mean time, running in windowed mode seems to have the textures working right. I'll be looking forward to that patch! :D
07-27-2009, 02:05 AM
cghislai Offline
Junior Member

Posts: 2
Threads: 0
Joined: May 2010
Reputation: 0
#13
Solved: 2 Years, 7 Months, 2 Weeks ago RE: 64-bit Archlinux using 32-bit chrooted environment, game fails to start
I also have some issue with archlinux on 64bit platform.

I use an intel i915 card on a thinkpad laptop. Intro plays fine, sounds is ok, i had to install lib32 xft in order to be able to launch the game.

I set all settings to low, tried windowed mode, but the issue alwyas happen.

When im in the first room, on a boat it appears, i can play for some seconds then the games hangs.

The log contains some errors:
Creating programs
CG: 'PostEffect_Blur_vp.cg' using profile: 'arbvp1'
CG: 'PostEffect_Blur_Rect_fp.cg' using profile: 'arbfp1'
CG: 'PostEffect_Blur_2D_fp.cg' using profile: 'arbfp1'
CG: 'PostEffect_Bloom_vp.cg' using profile: 'arbvp1'
CG: 'PostEffect_Bloom_fp.cg' using profile: 'arbfp1'
CG: 'PostEffect_Motion_vp.cg' using profile: 'arbvp1'
CG: 'PostEffect_Motion_fp.cg' using profile: 'arbfp1'
CG ERROR : "The compile returned an error."
-----------------------------------
core/programs/PostEffect_Motion_fp.cg(28) : error C5013: profile does not support "for" statements and "for" could not be unrolled.
-----------------------------------
CG: Error loading: 'core/programs/PostEffect_Motion_fp.cg'!
ERROR: Couldn't create program 'PostEffect_Motion_fp.cg'
Dynamic loops in motion blur fp not supported, loading static instead.
CG: 'PostEffect_Motion_staticloop_fp.cg' using profile: 'arbfp1'
CG: 'PostEffect_DoF_vp.cg' using profile: 'arbvp1'
CG: 'PostEffect_DoF_fp.cg' using profile: 'arbfp1'
  RendererPostEffects created
Adding engine materials
ame Running
--------------------------------------------------------
Loading collada for 'maps/level00_01_boat_cabin.dae' took: 167 ms
CG: 'Fog_Trans_vp.cg' using profile: 'arbvp1'
CG: 'Fog_Trans_Alpha_fp.cg' using profile: 'arbfp1'
CG: 'Fog_Trans_Mod_fp.cg' using profile: 'arbfp1'
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Bone 'joint1' is not attached to skin!
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
ERROR: Child body 'joint1' for joint 'sjoint2' in mesh 'boat_dynamicparaffin.dae' does not exist!
ERROR: Cannot find sub entity 'parrafinlight_joint1' in mesh 'boat_dynamicparaffin.dae'
Loading map 'level00_01_boat_cabin.dae' took: 1406 ms
WARNING: Could not find language file category ''

Note that as the game hangs, X doesn't respond to my input anymore. I can't alt-tab or switch desktop. I can however return to console to kill the process.

Thanks for your time

Charly
05-12-2010, 02:03 PM
Find
jens Offline
Frictional Games

Posts: 4,095
Threads: 199
Joined: Apr 2006
Reputation: 202
#14
Solved: 2 Years, 7 Months, 2 Weeks ago RE: 64-bit Archlinux using 32-bit chrooted environment, game fails to start
Hi,
I think it has a GMA950 integrated graphics or worse, which is not supported by the game. So it is not possible to run the game with it.
05-12-2010, 02:49 PM
Website Find
cghislai Offline
Junior Member

Posts: 2
Threads: 0
Joined: May 2010
Reputation: 0
#15
Solved: 2 Years, 7 Months, 2 Weeks ago RE: 64-bit Archlinux using 32-bit chrooted environment, game fails to start
Indeed, thats that chipset.

So bad i won't be able to play it. I remember playing the demo on my old box it looked very interesting....
05-13-2010, 04:35 PM
Find
Jump to the post that solved this thread.




Users browsing this thread: 1 Guest(s)