Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Force windowed mode on startup
kvsari
Unregistered

 
#1
Solved: 4 Years, 5 Months, 2 Weeks ago Force windowed mode on startup
How do I force SOMA to run in windowed mode on startup? Is there a command line option that overrides anything in the configuration files?

I purchased SOMA on Steam. While trying different video settings to make the game run smoothly, I ended up choosing a full-screen resolution which causes the game to go to a black screen and flicker with the mouse locking up. I have to kill SOMA before I can use X again. Now, whenever I try to run SOMA, it defaults to this botched setting and I can't do anything.

I've checked about deleting your user profile but I have none. There is no Main directory in my ~/.local/share/Steam/steamapps/common/SOMA root nor is there a <UserName_Number>_user_settings.cfg that I can find "find * | grep .cfg". I played the first ten seconds of the game before jumping out and starting to tweak video settings. I tried running Soma.bin.x86_64 -cfg config/main_init_dev.cfg but the graphics settings persist.
10-07-2015, 06:12 AM
Mudbill Offline
Muderator

Posts: 3,880
Threads: 59
Joined: Apr 2013
Reputation: 179
#2
Solved: 4 Years, 5 Months, 2 Weeks ago RE: Force windowed mode on startup
Check this directory: ~/.local/share/frictionalgames/SOMA/
You should be able to edit whether it's fullscreen or not, and also the specific resolution.

(This post was last modified: 10-07-2015, 07:24 AM by Mudbill.)
10-07-2015, 07:23 AM
Find
Guest
Unregistered

 
#3
Solved: 4 Years, 5 Months, 2 Weeks ago RE: Force windowed mode on startup
Thank you very much.
10-07-2015, 07:29 AM




Users browsing this thread: 1 Guest(s)