Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
DEMO could not load main init file: config/main_init.cfg
vikeyev Offline
Junior Member

Posts: 19
Threads: 2
Joined: Oct 2010
Reputation: 0
#1
Solved: 2 Years, 3 Months, 3 Weeks ago DEMO could not load main init file: config/main_init.cfg

Hello guys,

I am getting the error *could not load main init file: config/main_init.cfg* every time I attempt to start the demo.

I searched on google with no luck, in fact it sent me to this site on the mac section, but that didn't really help me. I searched through the forums and the only related threads I found were the mac one and one about the steam version.

CPU: AMD Athlon II x2 245
GPU: Radeon HD5770
MOBO: Asus M4A87TD/USB3
RAMM: 2GB corsair single channel (sorry can't remember much else about my memory)
PSU: 600 watt
HDD: 1TB Westgate 7200 rpm
OPTICAL DRIVES: 1 LG dvd burner (unsure about the details)
OS: Opensuse 11.2 32bit

I had a look in my AmnesiaDemo directory and I couldn't even find a file named main_init.cfg, I even used the find command in terminal and still nothing. Is it possible that I may have encountered an error during the installation? It didn't give me any error messages and it said it completed successfully. Oh and I do have fglrx driver installed and working.

I downloaded the demo from the gamers hell mirror on the amnesia game website.

Any help and advice you can give will be greatly appreciated, if you need any more info just holler.
Thank you for your time.

MOBO: Asus M4A87TD/USB3
CPU: AMD Athlon II x2 245
GPU: Radeon HD5770
RAM: Corsair VS2GB1333D3 2GB (1333MHz) DDR3 RAM, Non ECC Unbuffered, 9-9-9-24, 1.5V
PSU: 600 watt shark
HDD: West Gate 1TB 7200RPM SATA2
OS: Ubuntu 10.10
10-01-2010, 01:25 PM
Find
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
#2
Solved: 2 Years, 3 Months, 3 Weeks ago RE: DEMO could not load main init file: config/main_init.cfg

the main_init.cfg file in the config/ directory in the game install.

If it's not there then something went awry during installation, try reinstalling.

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
10-01-2010, 03:26 PM
Website Find
vikeyev Offline
Junior Member

Posts: 19
Threads: 2
Joined: Oct 2010
Reputation: 0
#3
Solved: 2 Years, 3 Months, 3 Weeks ago RE: DEMO could not load main init file: config/main_init.cfg

(10-01-2010, 03:26 PM)Urkle Wrote: the main_init.cfg file in the config/ directory in the game install.

If it's not there then something went awry during installation, try reinstalling.

I reinstalled but I haven't tried the game out yet, i believe it may have fixed my problem as their are about 10 more folders in the amnesia demo directory, in fact before I uninstalled the game i had a look and their wasn't even a config directory, something definitely went awry during installation, but the folder is their now. Thank you for your help.

EDIT: well the game is working but the sound isn't and I've tried changing it to all of the sound devices in game and yet it still doesn't work. Btw I did restart the game after each time of changing the device.

MOBO: Asus M4A87TD/USB3
CPU: AMD Athlon II x2 245
GPU: Radeon HD5770
RAM: Corsair VS2GB1333D3 2GB (1333MHz) DDR3 RAM, Non ECC Unbuffered, 9-9-9-24, 1.5V
PSU: 600 watt shark
HDD: West Gate 1TB 7200RPM SATA2
OS: Ubuntu 10.10
10-01-2010, 04:11 PM
Find
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
#4
Solved: 2 Years, 3 Months, 3 Weeks ago RE: DEMO could not load main init file: config/main_init.cfg

check the "libs" folder in the game install directory. Is there a symlink to "libopenal.so.1" there?

If not, probably your system openal library is broke. Run this command to tell the game to use the included openal
cd /install/dir/AmnesiaDemo
ln -s all/libopenal.so.1 libs/libopenal.so.1

If it IS there, then try installing the openal library in your distribution and re-run the "checklibs.sh" script.

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
10-01-2010, 04:29 PM
Website Find
vikeyev Offline
Junior Member

Posts: 19
Threads: 2
Joined: Oct 2010
Reputation: 0
#5
Solved: 2 Years, 3 Months, 3 Weeks ago RE: DEMO could not load main init file: config/main_init.cfg

(10-01-2010, 04:29 PM)Urkle Wrote: check the "libs" folder in the game install directory. Is there a symlink to "libopenal.so.1" there?

If not, probably your system openal library is broke. Run this command to tell the game to use the included openal
cd /install/dir/AmnesiaDemo
ln -s all/libopenal.so.1 libs/libopenal.so.1

If it IS there, then try installing the openal library in your distribution and re-run the "checklibs.sh" script.

WOOT cheers for that, I installed the openal library and it solved my problem thank you once again for your help.

EDIT: well i sure as hell won't be sleeping with the lights off after that, OMG that was some scary crap, I'm gonna buy the game now.

MOBO: Asus M4A87TD/USB3
CPU: AMD Athlon II x2 245
GPU: Radeon HD5770
RAM: Corsair VS2GB1333D3 2GB (1333MHz) DDR3 RAM, Non ECC Unbuffered, 9-9-9-24, 1.5V
PSU: 600 watt shark
HDD: West Gate 1TB 7200RPM SATA2
OS: Ubuntu 10.10
10-01-2010, 04:43 PM
Find
ladoga Offline
Junior Member

Posts: 7
Threads: 0
Joined: Aug 2010
Reputation: 0
#6
Solved: 2 Years, 3 Months, 3 Weeks ago RE: DEMO could not load main init file: config/main_init.cfg

Urkle never sleeps. Smile
10-01-2010, 09:33 PM
Find
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
#7
Solved: 2 Years, 3 Months, 3 Weeks ago RE: DEMO could not load main init file: config/main_init.cfg

Sleep? what's sleep?!?!?

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
10-01-2010, 09:53 PM
Website Find
Tokpojk Offline
Junior Member

Posts: 1
Threads: 0
Joined: Dec 2010
Reputation: 0
#8
Solved: 2 Years, 3 Months, 3 Weeks ago RE: DEMO could not load main init file: config/main_init.cfg

I'm having this "could not load main init file: config/main_init.cfg"-error, though, if I explore the the folders of amnesia I CAN find this file. Why's it still messing with me?
12-14-2010, 02:34 AM
Find
jens Offline
Frictional Games

Posts: 4,095
Threads: 199
Joined: Apr 2006
Reputation: 202
#9
Solved: 2 Years, 3 Months, 3 Weeks ago RE: DEMO could not load main init file: config/main_init.cfg

Try putting the game in another location, if I recall correctly it is because there is a permission problem. So if it is not in Applications, put it there and see how that works.

whups, did not pay attention and assumed it was for Mac Smile but could be a permission problem on Linux as well
(This post was last modified: 12-14-2010, 02:26 PM by jens.)
12-14-2010, 07:56 AM
Website Find
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
#10
Solved: 2 Years, 3 Months, 3 Weeks ago RE: DEMO could not load main init file: config/main_init.cfg

Tokpojk, what linux distribution are you using?
32bit or 64bit?
Selinux on or off?
Where did you install the game? (full path)
What is the default language of your system?

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
12-14-2010, 02:25 PM
Website Find




Users browsing this thread: 1 Guest(s)