Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support


Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Custom sounds not working!
Author Message
finScript Offline
Member

Posts: 57
Joined: Jan 2012
Reputation: 0
Post: #1
Custom sounds not working!

My sound file's name: sound_01_thunders_and_rain.ogg
I made an .snt file:
<SOUNDENTITY> <SOUNDS>    <Main>      <Sound File="sound_01_thunders_and_rain.ogg" />       </Main>   </SOUNDS>  <PROPERTIES Volume="0.5" MinDistance="20" MaxDistance="30" Random="1" Interval="0" FadeEnd="False" FadeStart="False" Stream="True" Loop="True" Use3D="False" Blockable="False" BlockVolumeMul="0.5" Priority="0" /></SOUNDENTITY>


Still it's not working when I try to put it in-game or use PlaySoundAtEntity()

04-22-2012 03:50 PM
Find all posts by this user Quote this message in a reply
JetlinerX Offline
Senior Member

Posts: 599
Joined: Jun 2011
Reputation: 19
Post: #2
RE: Custom sounds not working!

Need your in game script too.

Lead Developer of "The Attic"
~Slade Mitchell

Chapter 3 (REL)

04-22-2012 04:22 PM
Visit this user's website Find all posts by this user Quote this message in a reply
finScript Offline
Member

Posts: 57
Joined: Jan 2012
Reputation: 0
Post: #3
RE: Custom sounds not working!

(04-22-2012 04:22 PM)JetlinerX Wrote:  Need your in game script too.
Actually i mean with "in-game" that i select in level editor sounds and add my sound there

04-22-2012 06:02 PM
Find all posts by this user Quote this message in a reply
overscore Offline
Junior Member

Posts: 10
Joined: Apr 2012
Reputation: 1
Post: #4
RE: Custom sounds not working!

Try removing .ogg from the sound file name.
(This post was last modified: 04-23-2012 05:39 PM by overscore.)
04-23-2012 05:39 PM
Find all posts by this user Quote this message in a reply
Stepper321 Offline
Senior Member

Posts: 263
Joined: Nov 2011
Reputation: 8
Post: #5
RE: Custom sounds not working!

No, you need the .ogg, try following this tutorial: http://wiki.frictionalgames.com/hpl2/tut...cript/page

Signature to awesome to be displayed.
04-23-2012 05:51 PM
Find all posts by this user Quote this message in a reply
finScript Offline
Member

Posts: 57
Joined: Jan 2012
Reputation: 0
Post: #6
RE: Custom sounds not working!

(04-23-2012 05:51 PM)Stepper321 Wrote:  No, you need the .ogg, try following this tutorial: http://wiki.frictionalgames.com/hpl2/tut...cript/page
I've done my things just like in tutorial

04-23-2012 06:30 PM
Find all posts by this user Quote this message in a reply
Stepper321 Offline
Senior Member

Posts: 263
Joined: Nov 2011
Reputation: 8
Post: #7
RE: Custom sounds not working!

Can i get your script file please?

Signature to awesome to be displayed.
04-23-2012 07:16 PM
Find all posts by this user Quote this message in a reply
finScript Offline
Member

Posts: 57
Joined: Jan 2012
Reputation: 0
Post: #8
RE: Custom sounds not working!

(04-23-2012 07:16 PM)Stepper321 Wrote:  Can i get your script file please?
void OnStart(){
PlaySoundAtEntity("", "sound_01_thunders_and_rain.snt", "Player", 0, false);}

04-24-2012 06:22 PM
Find all posts by this user Quote this message in a reply
Stepper321 Offline
Senior Member

Posts: 263
Joined: Nov 2011
Reputation: 8
Post: #9
RE: Custom sounds not working!

(04-24-2012 06:22 PM)tappara97 Wrote:  
(04-23-2012 07:16 PM)Stepper321 Wrote:  Can i get your script file please?
void OnStart(){
PlaySoundAtEntity("", "sound_01_thunders_and_rain.snt", "Player", 0, false);
}
Mmmm, I ain't sure. Press enter after the ;, so it looks what i made it like in the quote, it's exactly the same function tough. Try it on 'void OnEnter(){ ... }'

Signature to awesome to be displayed.
04-25-2012 09:02 PM
Find all posts by this user Quote this message in a reply
Acies Offline
Posting Freak

Posts: 1,643
Joined: Feb 2011
Reputation: 73
Post: #10
RE: Custom sounds not working!

Remember to always render sounds used for PlaySoundAt in "Mono" format. Add that to your tutorial as well :>

[Image: mZiYnxe.png]


04-26-2012 01:13 AM
Find all posts by this user Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)