Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
problem with .lang files after unofficial patch install
MatthewTaylor92 Offline
Junior Member

Posts: 10
Threads: 5
Joined: Apr 2013
Reputation: 0
#1
Bug  problem with .lang files after unofficial patch install

sorry if it's a repost, but i really can't read 50 pages of comments below patch's thread(it's the unofficial 11.11.13 patch).

After patch installation all seems to work fine, but when i tried my custom story no messages appears at the beginning (i set theese with SetMessage() func in hps file of my first map). I didn't changed anything in both .lang and .hps files so where is the problem?

Immediatly after the patch installation i also followed the guide on frictional games documentation: setting up development envrioment. I modified some files in Documents as user_settings ecc.. maybe this can be the cause?

Thanks for help Smile
03-20-2014, 10:26 AM
Find Reply
Romulator Offline
Not Tech Support ;-)

Posts: 3,626
Threads: 62
Joined: Jan 2013
Reputation: 195
#2
RE: problem with .lang files after unofficial patch install

Could you post your extra_english.lang file, juussst in case?

Discord: Romulator#0001
[Image: 3f6f01a904.png]
03-20-2014, 10:47 AM
Find Reply
Mudbill Offline
Muderator

Posts: 3,877
Threads: 59
Joined: Apr 2013
Reputation: 178
#3
RE: problem with .lang files after unofficial patch install

I've heard other people also had trouble with their lang files after setting up the dev environment. I suspect you did something you shouldn't have.

03-20-2014, 11:33 AM
Find Reply
MatthewTaylor92 Offline
Junior Member

Posts: 10
Threads: 5
Joined: Apr 2013
Reputation: 0
#4
RE: problem with .lang files after unofficial patch install

(03-20-2014, 10:47 AM)Romulator Wrote: Could you post your extra_english.lang file, juussst in case?


<LANGUAGE>

<CATEGORY Name="CustomStoryMain">
<Entry Name="Description">...</Entry>
</CATEGORY>

<CATEGORY Name="Messages">
<Entry Name="Intro_1">"Foolery, sir, does walk about the orb like the sun; it shines everywhere.[br]William Shakespeare, Twelfth Night”</Entry>
</CATEGORY>

</LANGUAGE>

and the call in library.hps:

. . .
void Intro(string &in asTimer) {
string x = asTimer;
if (x == "T1") {
SetMessage("Messages", "Intro_1", 5); //"Foolery, sir... quote
PlaySoundAtEntity("", "ambience_dark_1", "Player", 0, false);
}
else if (x == "T2") {
. . .

I also tried to run the game directly from the new patched executable file, but nothing happens

i don't know why, but when i launch the map normally by the custom story menu it works.. but if i change the ShowMenu entry in main_settings.cfg to false (and so the map is loaded directly) it does not work anymore.. I don't know where can be the problem!
(This post was last modified: 03-20-2014, 05:24 PM by MatthewTaylor92.)
03-20-2014, 04:51 PM
Find Reply
Traggey Offline
is mildly amused

Posts: 3,256
Threads: 73
Joined: Feb 2012
Reputation: 185
#5
RE: problem with .lang files after unofficial patch install

Wrong forum, make sure to post where it belongs next time.
03-20-2014, 07:49 PM
Find Reply
Acies Offline
Posting Freak

Posts: 1,643
Threads: 60
Joined: Feb 2011
Reputation: 73
#6
RE: problem with .lang files after unofficial patch install

I'm also having this issue. Can't seem to make notes/quests work with the new patch and my full conversion. Have anyone successfully implemented that in a 'patched' fullconversion? Have tried to search for possible errors, but not coming up with much atm.. :[

[Image: mZiYnxe.png]


03-21-2014, 06:55 PM
Find Reply




Users browsing this thread: 1 Guest(s)